summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-27 06:59:06 +0100
committerRemi Collet <remi@remirepo.net>2020-02-27 06:59:06 +0100
commit7c285280a78dff0cb2632c380376cef3210d8100 (patch)
treee88e8390bfbfcdbce1ac45609a918f92a80016e8
parent58c0bc2d7a8b221a0ad28d7a47b95cf5a64e6fc9 (diff)
update to 1.2.10
sources from git snapshot
-rw-r--r--composer.json2
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-williamdes-mariadb-mysql-kbs.spec14
3 files changed, 39 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 12d180d..43b6549 100644
--- a/composer.json
+++ b/composer.json
@@ -5,7 +5,7 @@
"type": "library",
"readme": "https://github.com/williamdes/mariadb-mysql-kbs/blob/master/README.md",
"license": "MPL-2.0",
- "version": "1.2.9",
+ "version": "1.2.10",
"keywords": [
"mariadb",
"mysql",
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87a1c0b
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION, Commit=$COMMIT\n"
+
+echo "Cloning..."
+git clone --recursive https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
+
diff --git a/php-williamdes-mariadb-mysql-kbs.spec b/php-williamdes-mariadb-mysql-kbs.spec
index b654a98..0409a96 100644
--- a/php-williamdes-mariadb-mysql-kbs.spec
+++ b/php-williamdes-mariadb-mysql-kbs.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-williamdes-mariadb-mysql-kbs
#
-# Copyright (c) 2019 Remi Collet
+# Copyright (c) 2019-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -9,7 +9,7 @@
%global with_tests 0%{!?_without_tests:1}
# Github
-%global gh_commit 0da5be5f43c184f497c84e4865c9fd8f37f19d5d
+%global gh_commit 152fa144bd5f9fbdd3b5e764a506e239a730df83
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner williamdes
%global gh_project mariadb-mysql-kbs
@@ -22,13 +22,15 @@
%global major %nil
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.2.9
+Version: 1.2.10
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: An index of the MariaDB and MySQL Knowledge bases
License: MPLv2.0
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{?gh_short}.tar.gz
+# pull from github to retrieve full data
+Source0: %{name}-%{version}-%{?gh_short}.tgz
+Source1: makesrc.sh
Patch0: %{name}-layout.patch
@@ -149,6 +151,10 @@ exit $ret
%changelog
+* Thu Feb 27 2020 Remi Collet <remi@remirepo.net> - 1.2.10-1
+- update to 1.2.10
+- sources from git snapshot
+
* Mon Jan 27 2020 Remi Collet <remi@remirepo.net> - 1.2.9-1
- update to 1.2.9
- switch to phpunit8