summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-10-06 08:30:05 +0200
committerRemi Collet <fedora@famillecollet.com>2016-10-06 08:30:05 +0200
commite944271924cd89478a29fe217668da6908639dc6 (patch)
tree02d4a34dac84257240d23de503119bbeba2e37ce
parenta00bbd6e1ba4e078cb8b546c0250079295fe0739 (diff)
php-webmozart-path-util: add backport stuff
-rw-r--r--Makefile4
-rw-r--r--composer.json34
-rw-r--r--php-webmozart-path-util.spec22
3 files changed, 60 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..884ccac
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,34 @@
+{
+ "name": "webmozart/path-util",
+ "description": "A robust cross-platform utility for normalizing, comparing and modifying file paths.",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Bernhard Schussek",
+ "email": "bschussek@gmail.com"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.3",
+ "webmozart/assert": "~1.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4.6",
+ "sebastian/version": "^1.0.1"
+ },
+ "autoload": {
+ "psr-4": {
+ "Webmozart\\PathUtil\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Webmozart\\PathUtil\\Tests\\": "tests/"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.3-dev"
+ }
+ }
+}
diff --git a/php-webmozart-path-util.spec b/php-webmozart-path-util.spec
index 24a15b2..062d951 100644
--- a/php-webmozart-path-util.spec
+++ b/php-webmozart-path-util.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-webmozart-path-util, from
#
# Fedora spec file for php-webmozart-path-util
#
@@ -38,6 +39,7 @@ License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -108,14 +110,31 @@ AUTOLOAD
%install
+rm -rf %{buildroot}
+
mkdir -p %{buildroot}%{phpdir}/Webmozart/PathUtil
cp -rp src/* %{buildroot}%{phpdir}/Webmozart/PathUtil/
%check
%if %{with_tests}
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --bootstrap %{buildroot}%{phpdir}/Webmozart/PathUtil/autoload.php || ret=1
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit --bootstrap %{buildroot}%{phpdir}/Webmozart/PathUtil/autoload.php || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
%{_bindir}/phpunit --verbose \
--bootstrap %{buildroot}%{phpdir}/Webmozart/PathUtil/autoload.php
+# remirepo:2
+fi
+exit $ret
%else
: Tests skipped
%endif
@@ -130,5 +149,8 @@ cp -rp src/* %{buildroot}%{phpdir}/Webmozart/PathUtil/
%changelog
+* Thu Oct 6 2016 Remi Collet <remi@remirepo.net> - 2.3.0-1
+- backport for remi repo, add EL-5 stuff
+
* Wed Sep 28 2016 Shawn Iwinski <shawn@iwin.ski> - 2.3.0-1
- Initial package