summaryrefslogtreecommitdiffstats
path: root/php-webmozart-assert.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-webmozart-assert.spec')
-rw-r--r--php-webmozart-assert.spec28
1 files changed, 14 insertions, 14 deletions
diff --git a/php-webmozart-assert.spec b/php-webmozart-assert.spec
index 2ea734f..035fb25 100644
--- a/php-webmozart-assert.spec
+++ b/php-webmozart-assert.spec
@@ -14,23 +14,18 @@
%global bootstrap 0
%global github_owner webmozart
%global github_name assert
-%global github_version 1.10.0
-%global github_commit 6964c76c7804814a842473e0c8fd15bab0f18e25
+%global github_version 1.11.0
+%global github_commit 11cb2199493b2f8a3b53e7f19068fc6aac760991
%global composer_vendor webmozart
%global composer_project assert
-# "php": "^5.3.3 || ^7.0 || ^8.0"
-%global php_min_ver 5.3.3
+# "php": "^7.2 || ^8.0"
+%global php_min_ver 7.2
# PHPUnit
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
-%global phpunit_require phpunit7
-%global phpunit_exec phpunit7
-%else
-%global phpunit_require php-composer(phpunit/phpunit)
-%global phpunit_exec phpunit
-%endif
+%global phpunit_require phpunit8
+%global phpunit_exec phpunit8
%if %{bootstrap}
# Build using "--with tests" to enable tests
@@ -60,9 +55,9 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-ctype
BuildRequires: %{phpunit_require}
## phpcompatinfo (computed from version 1.7.0)
-BuildRequires: php-ctype
BuildRequires: php-filter
BuildRequires: php-mbstring
BuildRequires: php-pcre
@@ -75,8 +70,8 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 1.7.0)
Requires: php-ctype
+# phpcompatinfo (computed from version 1.7.0)
Requires: php-filter
Requires: php-mbstring
Requires: php-pcre
@@ -132,7 +127,7 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which %{phpunit_exec})
-for PHP_EXEC in php73 php74 php80 php81; do
+for PHP_EXEC in php74 php80 php81 php82; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC \
-d auto_prepend_file=%{buildroot}%{phpdir}/Webmozart/Assert/autoload.php \
@@ -157,6 +152,11 @@ exit $RETURN_CODE
%changelog
+* Mon Aug 8 2022 Remi Collet <remi@remirepo.net> - 1.11.0-1
+- update to 1.11.0
+- raise dependency on PHP 7.2
+- switch to phpunit8
+
* Fri Sep 24 2021 Remi Collet <remi@remirepo.net> - 1.10.0-1
- update to 1.10.0