summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-23 15:26:26 +0200
committerRemi Collet <remi@remirepo.net>2018-04-23 15:26:26 +0200
commitdc939fa62b29326db69a77c48b9b1e5a43129926 (patch)
tree85220efc24ef646fcff5e4659d7a4637ef8354ed
parenta52533a2a47360c88b5b5fcb2649bd45db6d5939 (diff)
v1.3.0 from Fedora:
* Sun Apr 22 2018 Shawn Iwinski <shawn@iwin.ski> - 1.3.0-1 - Update to 1.3.0 (RHBZ #1539946) - Add get source script - Add composer.json to repo - Update running of tests
-rw-r--r--.gitignore9
-rwxr-xr-xphp-webmozart-assert-get-source.sh73
-rw-r--r--php-webmozart-assert.spec60
3 files changed, 116 insertions, 26 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..6f69818
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-webmozart-assert-get-source.sh b/php-webmozart-assert-get-source.sh
new file mode 100755
index 0000000..b2ac62b
--- /dev/null
+++ b/php-webmozart-assert-get-source.sh
@@ -0,0 +1,73 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+SPEC_DIR=`pwd`
+
+print "SPEC_DIR = $SPEC_DIR"
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ TAR_FILE=${SPEC_DIR}/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-webmozart-assert.spec b/php-webmozart-assert.spec
index a110478..0f955b3 100644
--- a/php-webmozart-assert.spec
+++ b/php-webmozart-assert.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-webmozart-assert
#
-# Copyright (c) 2016 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016,2018 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner webmozart
%global github_name assert
-%global github_version 1.2.0
-%global github_commit 2db61e59ff05fe5126d152bd0655c9ea113e550f
+%global github_version 1.3.0
+%global github_commit 0df1908962e7a3071564e857d86874dad1ef204a
%global composer_vendor webmozart
%global composer_project assert
@@ -34,16 +34,19 @@ Summary: Assertions to validate method input/output with nice error messag
Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
-Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+# GitHub export does not include tests.
+# Run php-webmozart-assert-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+
BuildArch: noarch
# Tests
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 1.2.0)
+## phpcompatinfo (computed from version 1.3.0)
BuildRequires: php-ctype
BuildRequires: php-mbstring
BuildRequires: php-pcre
@@ -54,7 +57,7 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 1.2.0)
+# phpcompatinfo (computed from version 1.3.0)
Requires: php-ctype
Requires: php-mbstring
Requires: php-pcre
@@ -90,43 +93,42 @@ cat <<'AUTOLOAD' | tee src/autoload.php
*/
require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('Webmozart\\Assert\\', __DIR__);
+\Fedora\Autoloader\Dependencies::required(array(
+ __DIR__.'/Assert.php',
+));
AUTOLOAD
%install
-rm -rf %{buildroot}
-
-mkdir -p %{buildroot}%{phpdir}/Webmozart/Assert
-cp -rp src/* %{buildroot}%{phpdir}/Webmozart/Assert/
+mkdir -p %{buildroot}%{phpdir}/Webmozart
+cp -rp src %{buildroot}%{phpdir}/Webmozart/Assert
%check
%if %{with_tests}
-BOOTSTRAP=%{buildroot}%{phpdir}/Webmozart/Assert/autoload.php
+: Create tests bootstrap
+cat <<'BOOTSTRAP' | tee bootstrap.php
+<?php
+require_once '%{buildroot}%{phpdir}/Webmozart/Assert/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('Webmozart\\Assert\\Tests\\', __DIR__.'/tests');
+BOOTSTRAP
: Upstream tests
-%{_bindir}/phpunit --verbose --bootstrap $BOOTSTRAP
-
-: Upstream tests with SCLs if available
-SCL_RETURN_CODE=0
-for SCL in php56 php70 php71; do
- if which $SCL; then
- $SCL %{_bindir}/phpunit --verbose --bootstrap $BOOTSTRAP || SCL_RETURN_CODE=1
+RETURN_CODE=0
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in "" %{?rhel:php54 php55 php56} php70 php71 php72; do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
+ || RETURN_CODE=1
fi
done
-exit $SCL_RETURN_CODE
+exit $RETURN_CODE
%else
: Tests skipped
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -136,6 +138,12 @@ rm -rf %{buildroot}
%changelog
+* Sun Apr 22 2018 Shawn Iwinski <shawn@iwin.ski> - 1.3.0-1
+- Update to 1.3.0 (RHBZ #1539946)
+- Add get source script
+- Add composer.json to repo
+- Update running of tests
+
* Tue Dec 27 2016 Shawn Iwinski <shawn@iwin.ski> - 1.2.0-1
- Update to 1.2.0 (RHBZ #1398043)
- Use php-composer(fedora/autoloader)