summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-24 08:04:43 +0200
committerRemi Collet <remi@remirepo.net>2021-09-24 08:04:43 +0200
commit3c4e0ac6da25752a2c39fbb35a9b2e1dbcb93577 (patch)
tree9fdd9a0dbae826db3cc4fddf18978973b7079b7e
parenta0ff3ec9e173f8b259a8dff0d8194ea40ab6bc99 (diff)
update to 1.10.0
-rw-r--r--composer.json8
-rw-r--r--php-webmozart-assert.spec15
2 files changed, 16 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 34350b2..2e609b6 100644
--- a/composer.json
+++ b/composer.json
@@ -14,14 +14,15 @@
}
],
"require": {
- "php": "^5.3.3 || ^7.0",
+ "php": "^5.3.3 || ^7.0 || ^8.0",
"symfony/polyfill-ctype": "^1.8"
},
"require-dev": {
"phpunit/phpunit": "^4.8.36 || ^7.5.13"
},
"conflict": {
- "vimeo/psalm": "<3.6.0"
+ "vimeo/psalm": "<3.9.1",
+ "phpstan/phpstan": "<0.12.20"
},
"autoload": {
"psr-4": {
@@ -30,7 +31,8 @@
},
"autoload-dev": {
"psr-4": {
- "Webmozart\\Assert\\Tests\\": "tests/"
+ "Webmozart\\Assert\\Tests\\": "tests/",
+ "Webmozart\\Assert\\Bin\\": "bin/src"
}
}
}
diff --git a/php-webmozart-assert.spec b/php-webmozart-assert.spec
index 5e3e26d..2ea734f 100644
--- a/php-webmozart-assert.spec
+++ b/php-webmozart-assert.spec
@@ -14,13 +14,13 @@
%global bootstrap 0
%global github_owner webmozart
%global github_name assert
-%global github_version 1.7.0
-%global github_commit aed98a490f9a8f78468232db345ab9cf606cf598
+%global github_version 1.10.0
+%global github_commit 6964c76c7804814a842473e0c8fd15bab0f18e25
%global composer_vendor webmozart
%global composer_project assert
-# "php": "^5.3.3 || ^7.0"
+# "php": "^5.3.3 || ^7.0 || ^8.0"
%global php_min_ver 5.3.3
# PHPUnit
@@ -126,12 +126,13 @@ cp -rp src %{buildroot}%{phpdir}/Webmozart/Assert
cat <<'BOOTSTRAP' | tee bootstrap.php
<?php
\Fedora\Autoloader\Autoload::addPsr4('Webmozart\\Assert\\Tests\\', __DIR__.'/tests');
+\Fedora\Autoloader\Autoload::addPsr4('Webmozart\\Assert\\Bin\\', __DIR__.'/bin/src');
BOOTSTRAP
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which %{phpunit_exec})
-for PHP_EXEC in php %{?rhel:php54 php55 php56 php70 php71} php72 php73 php74; do
+for PHP_EXEC in php73 php74 php80 php81; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC \
-d auto_prepend_file=%{buildroot}%{phpdir}/Webmozart/Assert/autoload.php \
@@ -156,6 +157,12 @@ exit $RETURN_CODE
%changelog
+* Fri Sep 24 2021 Remi Collet <remi@remirepo.net> - 1.10.0-1
+- update to 1.10.0
+
+* Tue Jul 21 2020 Remi Collet <remi@remirepo.net> - 1.9.1-1
+- update to 1.9.1
+
* Sun Feb 23 2020 Shawn Iwinski <shawn@iwin.ski> - 1.7.0-1
- Update to 1.7.0 (RHBZ #1746998)
- Disable bootstrap so tests run by default