summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore9
-rw-r--r--composer.json12
-rw-r--r--php-webimpress-safe-writer.spec36
3 files changed, 34 insertions, 23 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index a88254e..fad2280 100644
--- a/composer.json
+++ b/composer.json
@@ -10,12 +10,12 @@
"race condition"
],
"require": {
- "php": "^7.2 || ^8.0"
+ "php": "^7.3 || ^8.0"
},
"require-dev": {
- "phpunit/phpunit": "^8.5.8 || ^9.3.7",
- "vimeo/psalm": "^3.14.2",
- "webimpress/coding-standard": "^1.1.5"
+ "phpunit/phpunit": "^9.5.4",
+ "vimeo/psalm": "^4.7",
+ "webimpress/coding-standard": "^1.2.2"
},
"autoload": {
"psr-4": {
@@ -32,8 +32,8 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.1.x-dev",
- "dev-develop": "2.2.x-dev",
+ "dev-master": "2.2.x-dev",
+ "dev-develop": "2.3.x-dev",
"dev-release-1.0": "1.0.x-dev"
}
},
diff --git a/php-webimpress-safe-writer.spec b/php-webimpress-safe-writer.spec
index a3cad0e..cf44763 100644
--- a/php-webimpress-safe-writer.spec
+++ b/php-webimpress-safe-writer.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-webimpress-safe-writer
#
-# Copyright (c) 2020 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2020-2021 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -10,19 +10,18 @@
# Please preserve changelog entries
#
+%bcond_without tests
+
%global github_owner webimpress
%global github_name safe-writer
-%global github_version 2.1.0
-%global github_commit 5cfafdec5873c389036f14bf832a5efc9390dcdd
+%global github_version 2.2.0
+%global github_commit 9d37cc8bee20f7cb2f58f6e23e05097eab5072e6
%global composer_vendor webimpress
%global composer_project safe-writer
-# "php": "^7.2 || ^8.0"
-%global php_min_ver 7.2
-
-# Build using "--without tests" to disable tests
-%global with_tests 0%{!?_without_tests:1}
+# "php": "^7.3 || ^8.0"
+%global php_min_ver 7.3
%{!?phpdir: %global phpdir %{_datadir}/php}
@@ -41,10 +40,10 @@ Source1: %{name}-get-source.sh
BuildArch: noarch
# Tests
-%if %{with_tests}
+%if %{with tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: phpunit8 >= 8.5.8
+BuildRequires: phpunit9 >= 9.5.4
## phpcompatinfo for version 2.0.0
BuildRequires: php-json
BuildRequires: php-spl
@@ -95,18 +94,15 @@ cp -rp src %{buildroot}%{phpdir}/Webimpress/SafeWriter
%check
-%if %{with_tests}
-: Skip test known to fail in mock environment
-sed 's/function testMultipleWriters/function SKIP_testMultipleWriters/' \
- -i test/FileWriterTest.php
-
+%if %{with tests}
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit8)
-for PHP_EXEC in php php72 php73 php74 php80; do
+PHPUNIT=$(which phpunit9)
+for PHP_EXEC in php php73 php74 php80; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose \
--bootstrap %{buildroot}%{phpdir}/Webimpress/SafeWriter/autoload.php \
+ --filter '^((?!(testMultipleWriters)).)*$' \
|| RETURN_CODE=1
fi
done
@@ -117,6 +113,7 @@ exit $RETURN_CODE
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -126,6 +123,11 @@ exit $RETURN_CODE
%changelog
+* Tue Apr 20 2021 Remi Collet <remi@remirepo.net> - 2.2.0-1
+- update to 2.2.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Tue Aug 25 2020 Remi Collet <remi@remirepo.net> - 2.1.0-1
- update to 2.1.0