summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-webimpress-http-middleware-compatibility.spec24
1 files changed, 13 insertions, 11 deletions
diff --git a/php-webimpress-http-middleware-compatibility.spec b/php-webimpress-http-middleware-compatibility.spec
index 66d5a20..d5849c0 100644
--- a/php-webimpress-http-middleware-compatibility.spec
+++ b/php-webimpress-http-middleware-compatibility.spec
@@ -1,13 +1,14 @@
# remirepo/fedora spec file for php-webimpress-http-middleware-compatibility
#
-# Copyright (c) 2020 Remi Collet
+# Copyright (c) 2020-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
+
# Github
%global gh_commit 8ed1c2c7523dce0035b98bc4f3a73ca9cd1d3717
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
@@ -20,7 +21,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Version: 0.1.4
-Release: 2%{?dist}
+Release: 6%{?dist}
Summary: Compatibility library for Draft PSR-15 HTTP Middleware
License: BSD
@@ -29,21 +30,19 @@ Source0: %{name}-%{version}-%{?gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
BuildRequires: php(language) >= 5.4
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(http-interop/http-middleware) > 0.1.1 with php-composer(http-interop/http-middleware) < 0.6)
# For tests, from composer.json "require-dev": {
# "phpunit/phpunit": "^5.7.23 || ^6.4.3"
-BuildRequires: phpunit6 > 6.4.3
-%global phpunit %{_bindir}/phpunit6
-# remirepo:5
+# remirepo:3
%else
BuildRequires: php-composer(http-interop/http-middleware)
-BuildRequires: php-composer(phpunit/phpunit) >= 5.7.23
-%global phpunit %{_bindir}/phpunit
%endif
+BuildRequires: phpunit9
+%global phpunit %{_bindir}/phpunit9
%endif
# From composer.json, "require": {
@@ -100,7 +99,7 @@ cp -pr autoload %{buildroot}%{_datadir}/php/%{pk_vendor}/%{pk_project}%{major}
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
@@ -108,7 +107,7 @@ require '%{buildroot}%{_datadir}/php/%{pk_vendor}/%{pk_project}%{major}/autoload
EOF
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd %{phpunit} --no-coverage --verbose || ret=1
fi
@@ -130,6 +129,9 @@ exit $ret
%changelog
+* Tue Mar 23 2021 Remi Collet <remi@remirepo.net> - 0.1.4-6
+- switch to phpunit9
+
* Tue Jan 14 2020 Remi Collet <remi@remirepo.net> - 0.1.4-2
- own /usr/share/php/webimpress #1789783