summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-19 11:49:50 +0200
committerRemi Collet <remi@remirepo.net>2019-06-19 11:49:50 +0200
commit0007dcc59fd4a20e5420762cee4d501aa072cc8e (patch)
tree273c6eca9bf36df6a5c9acd1fbc4da2f58fe917b
parent1b001ed2b6e76f54c14f54f5f2ae106da7a71a08 (diff)
v2.6.1 from FedoraHEADmaster
-rw-r--r--composer.json9
l---------makesrc.sh1
-rw-r--r--php-vlucas-phpdotenv.spec18
3 files changed, 17 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 2abf464..e1126ec 100644
--- a/composer.json
+++ b/composer.json
@@ -2,7 +2,7 @@
"name": "vlucas/phpdotenv",
"description": "Loads environment variables from `.env` to `getenv()`, `$_ENV` and `$_SERVER` automagically.",
"keywords": ["env", "dotenv", "environment"],
- "license" : "BSD-3-Clause-Attribution",
+ "license" : "BSD-3-Clause",
"authors" : [
{
"name": "Vance Lucas",
@@ -11,10 +11,11 @@
}
],
"require": {
- "php": ">=5.3.9"
+ "php": ">=5.3.9",
+ "symfony/polyfill-ctype": "^1.9"
},
"require-dev": {
- "phpunit/phpunit": "^4.8 || ^5.0"
+ "phpunit/phpunit": "^4.8.35 || ^5.0"
},
"autoload": {
"psr-4": {
@@ -23,7 +24,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.4-dev"
+ "dev-master": "2.6-dev"
}
}
}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..5deae94
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-vlucas-phpdotenv-get-source.sh \ No newline at end of file
diff --git a/php-vlucas-phpdotenv.spec b/php-vlucas-phpdotenv.spec
index f7a6afc..416ccbf 100644
--- a/php-vlucas-phpdotenv.spec
+++ b/php-vlucas-phpdotenv.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-vlucas-phpdotenv
#
-# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner vlucas
%global github_name phpdotenv
-%global github_version 2.4.0
-%global github_commit 3cc116adbe4b11be5ec557bf1d24dc5e3a21d18c
+%global github_version 2.6.1
+%global github_commit 2a7dcf7e3e02dc5e701004e51a6f304b713107d5
%global composer_vendor vlucas
%global composer_project phpdotenv
@@ -31,7 +31,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: Loads environment variables from .env
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{github_owner}/%{github_name}
@@ -46,8 +45,9 @@ BuildArch: noarch
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 2.4.0)
+## phpcompatinfo (computed from version 2.6.1)
BuildRequires: php-ctype
+BuildRequires: php-filter
BuildRequires: php-pcre
BuildRequires: php-spl
## Autoloader
@@ -56,8 +56,9 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 2.4.0)
+# phpcompatinfo (computed from version 2.6.1)
Requires: php-ctype
+Requires: php-filter
Requires: php-pcre
Requires: php-spl
# Autoloader
@@ -105,7 +106,7 @@ cp -rp src %{buildroot}%{phpdir}/Dotenv
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71 php72; do
+for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71 php72 php73 php74; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
pwd
ls
@@ -129,5 +130,8 @@ exit $RETURN_CODE
%changelog
+* Sun Jun 16 2019 Shawn Iwinski <shawn@iwin.ski> - 2.6.1-1
+- Update to 2.6.1
+
* Sun Aug 20 2017 Shawn Iwinski <shawn@iwin.ski> - 2.4.0-1
- Initial package