summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-13 13:10:15 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-13 13:10:15 +0200
commite786ae947a90d83447705132144a8928f65c2878 (patch)
tree2340876474b030558a5f1969ef992fcd659c6c4f
parent1506adcd3862f0d58f9bbf2c2a71f619314d239e (diff)
php-udan11-sql-parser: 3.4.5
-rw-r--r--composer.json3
-rw-r--r--php-udan11-sql-parser-autoload.patch12
-rw-r--r--php-udan11-sql-parser.spec14
3 files changed, 17 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index d3d3f17..d41c1e3 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,8 @@
"source": "https://github.com/phpmyadmin/sql-parser"
},
"require": {
- "php": ">=5.4.0"
+ "php": ">=5.4.0",
+ "ext-mbstring": "*"
},
"require-dev": {
"phpunit/php-code-coverage": "~2.0 || ~3.0",
diff --git a/php-udan11-sql-parser-autoload.patch b/php-udan11-sql-parser-autoload.patch
index a6bd9da..700f51e 100644
--- a/php-udan11-sql-parser-autoload.patch
+++ b/php-udan11-sql-parser-autoload.patch
@@ -1,6 +1,6 @@
diff -up bin/highlight-query.rpm bin/highlight-query
---- bin/highlight-query.rpm 2016-07-26 08:44:20.461742790 +0200
-+++ bin/highlight-query 2016-07-26 08:44:57.594944077 +0200
+--- bin/highlight-query.rpm 2016-09-13 13:04:29.517214693 +0200
++++ bin/highlight-query 2016-09-13 13:05:35.400519256 +0200
@@ -1,29 +1,7 @@
#!/usr/bin/env php
<?php
@@ -24,7 +24,7 @@ diff -up bin/highlight-query.rpm bin/highlight-query
-if (!$found) {
- die(
- "You need to set up the project dependencies using the following commands:" . PHP_EOL .
-- "curl -s http://getcomposer.org/installer | php" . PHP_EOL .
+- "curl -sS https://getcomposer.org/installer | php" . PHP_EOL .
- "php composer.phar install" . PHP_EOL
- );
-}
@@ -33,8 +33,8 @@ diff -up bin/highlight-query.rpm bin/highlight-query
$cli = new SqlParser\Utils\CLI();
exit($cli->runHighlight());
diff -up bin/lint-query.rpm bin/lint-query
---- bin/lint-query.rpm 2016-07-26 08:44:29.869793788 +0200
-+++ bin/lint-query 2016-07-26 08:45:05.123984889 +0200
+--- bin/lint-query.rpm 2016-09-13 13:04:29.517214693 +0200
++++ bin/lint-query 2016-09-13 13:05:58.585626435 +0200
@@ -1,29 +1,7 @@
#!/usr/bin/env php
<?php
@@ -58,7 +58,7 @@ diff -up bin/lint-query.rpm bin/lint-query
-if (!$found) {
- die(
- "You need to set up the project dependencies using the following commands:" . PHP_EOL .
-- "curl -s http://getcomposer.org/installer | php" . PHP_EOL .
+- "curl -sS https://getcomposer.org/installer | php" . PHP_EOL .
- "php composer.phar install" . PHP_EOL
- );
-}
diff --git a/php-udan11-sql-parser.spec b/php-udan11-sql-parser.spec
index 95e5212..ecc7641 100644
--- a/php-udan11-sql-parser.spec
+++ b/php-udan11-sql-parser.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 1ec169a2a76110bbd0734da23a43c4d23c1eecfb
+%global gh_commit 98c2a72dd19542d80dcee63eb50c199e5f9a2935
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpmyadmin
#global gh_date 20150820
@@ -15,7 +15,7 @@
%global psr0 SqlParser
Name: php-udan11-%{gh_project}
-Version: 3.4.4
+Version: 3.4.5
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A validating SQL lexer and parser with a focus on MySQL dialect
@@ -40,11 +40,12 @@ BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-composer(theseer/autoload)
# From composer.json, "require": {
-# "php": ">=5.4.0"
+# "php": ">=5.4.0",
+# "ext-mbstring": "*"
Requires: php(language) >= 5.4
-# From phpcompatinfo report for 20150629
-Requires: php-ctype
Requires: php-mbstring
+# From phpcompatinfo report for 3.4.5
+Requires: php-ctype
Requires: php-pcre
# For generated autoloader
Requires: php-spl
@@ -138,6 +139,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Sep 13 2016 Remi Collet <remi@fedoraproject.org> - 3.4.5-1
+- update to 3.4.5
+
* Tue Jul 26 2016 Remi Collet <remi@fedoraproject.org> - 3.4.4-1
- update to 3.4.4
- switch from udan11/sql-parser to phpmyadmin/sql-parser