summaryrefslogtreecommitdiffstats
path: root/php-typo3-phar-stream-wrapper.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-typo3-phar-stream-wrapper.spec')
-rw-r--r--php-typo3-phar-stream-wrapper.spec19
1 files changed, 13 insertions, 6 deletions
diff --git a/php-typo3-phar-stream-wrapper.spec b/php-typo3-phar-stream-wrapper.spec
index bc75f48..910d294 100644
--- a/php-typo3-phar-stream-wrapper.spec
+++ b/php-typo3-phar-stream-wrapper.spec
@@ -12,8 +12,8 @@
%global github_owner TYPO3
%global github_name phar-stream-wrapper
-%global github_version 3.1.1
-%global github_commit fff6f5e037882f816cd41a9f5ccd8d8f97bfdebf
+%global github_version 3.1.3
+%global github_commit 586ff60beea128e069a5dc271d3d8133a9bc460a
%global composer_vendor typo3
%global composer_project phar-stream-wrapper
@@ -47,9 +47,10 @@ BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-fileinfo
BuildRequires: php-json
-## phpcompatinfo for version 3.1.1
+## phpcompatinfo for version 3.1.2
BuildRequires: php-pcre
BuildRequires: php-pecl(opcache)
+BuildRequires: php-reflection
BuildRequires: php-spl
## Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -57,9 +58,8 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-Requires: php-fileinfo
Requires: php-json
-# phpcompatinfo for version 3.1.1
+# phpcompatinfo for version 3.1.2
Requires: php-pcre
Requires: php-spl
# Autoloader
@@ -67,6 +67,7 @@ Requires: php-composer(fedora/autoloader)
# Weak dependencies
%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
+Suggests: php-fileinfo
Suggests: php-pecl(opcache)
%endif
@@ -121,7 +122,7 @@ rm -f tests/Functional/Interceptor/PharExtensionInterceptorTest.php
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php php71 php72 php73; do
+for PHP_EXEC in php php71 php72 php73 php74; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php || RETURN_CODE=1
fi
@@ -142,6 +143,12 @@ exit $RETURN_CODE
%changelog
+* Sat Nov 16 2019 Shawn Iwinski <shawn@iwin.ski> - 3.1.3-1
+- Update to 3.1.3 (RHBZ #1763201)
+
+* Sun Jun 16 2019 Shawn Iwinski <shawn@iwin.ski> - 3.1.2-1
+- Update to 3.1.2
+
* Wed May 08 2019 Shawn Iwinski <shawn@iwin.ski> - 3.1.1-1
- Update to 3.1.1 (RHBZ #1708651, #1708646, #1708649)
- https://typo3.org/security/advisory/typo3-psa-2019-007/