summaryrefslogtreecommitdiffstats
path: root/php-twig3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-twig3.spec')
-rw-r--r--php-twig3.spec40
1 files changed, 32 insertions, 8 deletions
diff --git a/php-twig3.spec b/php-twig3.spec
index ce14742..a234d25 100644
--- a/php-twig3.spec
+++ b/php-twig3.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-twig3
#
-# Copyright (c) 2014-2022 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2014-2023 Shawn Iwinski <shawn.iwinski@gmail.com>
# Remi Collet <remi@fedoraproject.org>
#
# License: MIT
@@ -14,7 +14,7 @@
%global github_owner twigphp
%global github_name Twig
-%global github_commit ed19f4bf9d19c4ef920b5d8243910bd32e85b9ba
+%global github_commit 7e7d5839d4bec168dfeef0ac66d5c5a2edbabffd
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor twig
@@ -27,11 +27,11 @@
%global phpdir %{_datadir}/php
Name: php-%{composer_project}%{major}
-Version: 3.4.0
+Version: 3.6.1
Release: 1%{?dist}
Summary: The flexible, fast, and secure template engine for PHP
-License: BSD
+License: BSD-3-Clause
URL: https://twig.symfony.com
Source0: %{name}-%{version}-%{github_short}.tgz
Source1: makesrc.sh
@@ -45,10 +45,10 @@ BuildRequires: php-fedora-autoloader-devel
BuildRequires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
+BuildRequires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 3)
# remirepo:4
%else
-BuildRequires: php-psr-container < 2
+BuildRequires: php-psr-container < 3
BuildRequires: php-psr-container >= 1.0
%endif
%global phpunit %{_bindir}/phpunit9
@@ -133,7 +133,10 @@ cat << 'EOF' | tee -a vendor/autoload.php
require_once '%{buildroot}%{phpdir}/Twig%{major}/autoload.php';
// Dependencies (require-dev)
\Fedora\Autoloader\Dependencies::required([
- '%{phpdir}/Psr/Container/autoload.php',
+ [
+ '%{phpdir}/Psr/Container2/autoload.php',
+ '%{phpdir}/Psr/Container/autoload.php',
+ ],
]);
EOF
@@ -142,7 +145,7 @@ sed -e '/listener/d' phpunit.xml.dist > phpunit.xml
RETURN_CODE=0
: Upstream tests with SCLs if available
-for SCL in "php %{phpunit}" php74 php80 php81; do
+for SCL in "php %{phpunit}" php80 php81 php82; do
if which $SCL; then
set $SCL
$1 ${2:-%{_bindir}/phpunit9} \
@@ -164,6 +167,27 @@ exit $RETURN_CODE
%changelog
+* Mon Jun 12 2023 Remi Collet <remi@remirepo.net> - 3.6.1-1
+- update to 3.6.1
+
+* Thu May 4 2023 Remi Collet <remi@remirepo.net> - 3.6.0-1
+- update to 3.6.0
+
+* Wed Feb 8 2023 Remi Collet <remi@remirepo.net> - 3.5.1-1
+- update to 3.5.1
+
+* Tue Jan 3 2023 Remi Collet <remi@remirepo.net> - 3.5.0-1
+- update to 3.5.0
+
+* Thu Sep 29 2022 Remi Collet <remi@remirepo.net> - 3.4.3-1
+- update to 3.4.3
+
+* Tue Aug 16 2022 Remi Collet <remi@remirepo.net> - 3.4.2-1
+- update to 3.4.2
+
+* Tue May 17 2022 Remi Collet <remi@remirepo.net> - 3.4.1-1
+- update to 3.4.1
+
* Mon May 16 2022 Remi Collet <remi@remirepo.net> - 3.4.0-1
- update to 3.4.0