summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-twig3.spec10
2 files changed, 8 insertions, 4 deletions
diff --git a/composer.json b/composer.json
index a17e501..f250e00 100644
--- a/composer.json
+++ b/composer.json
@@ -44,7 +44,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "3.0-dev"
+ "dev-master": "3.1-dev"
}
}
}
diff --git a/php-twig3.spec b/php-twig3.spec
index 8bcf75c..93e287c 100644
--- a/php-twig3.spec
+++ b/php-twig3.spec
@@ -14,7 +14,7 @@
%global github_owner twigphp
%global github_name Twig
-%global github_commit 9b76b1535483cdf4edf01bb787b0217b62bd68a5
+%global github_commit 9a29e1fa7b5431969f96878b8662e3fcb18601b7
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor twig
@@ -27,7 +27,7 @@
%global phpdir %{_datadir}/php
Name: php-%{composer_project}%{major}
-Version: 3.0.5
+Version: 3.1.0
Release: 1%{?dist}
Summary: The flexible, fast, and secure template engine for PHP
@@ -41,7 +41,8 @@ BUildArch: noarch
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# For tests
-BuildRequires: php(language) >= %{php_min_ver}
+# as we use phpunit9 (for assertFileDoesNotExist)
+BuildRequires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
@@ -164,6 +165,9 @@ exit $RETURN_CODE
%changelog
+* Wed Oct 21 2020 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+
* Tue Aug 11 2020 Remi Collet <remi@remirepo.net> - 3.0.5-1
- update to 3.0.5
- switch to phpunit9