summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-twig3.spec7
1 files changed, 4 insertions, 3 deletions
diff --git a/php-twig3.spec b/php-twig3.spec
index 8e8af52..8bcf75c 100644
--- a/php-twig3.spec
+++ b/php-twig3.spec
@@ -10,7 +10,8 @@
#
# Please preserve changelog entries
#
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
+
%global github_owner twigphp
%global github_name Twig
%global github_commit 9b76b1535483cdf4edf01bb787b0217b62bd68a5
@@ -38,7 +39,7 @@ Source1: makesrc.sh
BUildArch: noarch
## Autoloader
BuildRequires: php-fedora-autoloader-devel
-%if %{with_tests}
+%if %{with tests}
# For tests
BuildRequires: php(language) >= %{php_min_ver}
# remirepo:1
@@ -122,7 +123,7 @@ cp -rp src %{buildroot}%{phpdir}/Twig%{major}
%{_bindir}/php -r 'require_once "%{buildroot}%{phpdir}/Twig%{major}/autoload.php";
exit(version_compare("%{version}", Twig\Environment::VERSION, "=") ? 0 : 1);'
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
phpab --output vendor/autoload.php tests