summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-21 16:16:02 +0200
committerRemi Collet <remi@remirepo.net>2020-10-21 16:16:02 +0200
commit98cf9d10ce325d80c026d3ebca1c1238fd965c6f (patch)
tree2a67abdcc1427c5e285cabab475d82ade6c7e02b
parentd02ef005b32bcbe5b213e071c4b2822835b0a355 (diff)
update to 2.14.0
raise dependency on PHP 7.2.5
-rw-r--r--composer.json4
-rw-r--r--php-twig2.spec18
2 files changed, 12 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index fb474d8..8f45b4b 100644
--- a/composer.json
+++ b/composer.json
@@ -24,7 +24,7 @@
}
],
"require": {
- "php": ">=7.1.3",
+ "php": ">=7.2.5",
"symfony/polyfill-mbstring": "^1.3",
"symfony/polyfill-ctype": "^1.8"
},
@@ -47,7 +47,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.13-dev"
+ "dev-master": "2.14-dev"
}
}
}
diff --git a/php-twig2.spec b/php-twig2.spec
index 091da43..15feacc 100644
--- a/php-twig2.spec
+++ b/php-twig2.spec
@@ -14,18 +14,18 @@
%global github_owner twigphp
%global github_name Twig
-%global github_commit 57e96259776ddcacf1814885fc3950460c8e18ef
+%global github_commit d495243dade48c39b6a5261c26cdbd8c5703f6a0
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor twig
%global composer_project twig
-# "php": ">=7.1.3"
-%global php_min_ver 7.1.3
+# "php": ">=7.2.5"
+%global php_min_ver 7.2.5
%global phpdir %{_datadir}/php
Name: php-%{composer_project}2
-Version: 2.13.1
+Version: 2.14.0
Release: 1%{?dist}
Summary: The flexible, fast, and secure template engine for PHP
@@ -39,7 +39,8 @@ BUildArch: noarch
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# For tests
-BuildRequires: php(language) >= 7.1
+# as we use phpunit9 (for assertFileDoesNotExist)
+BuildRequires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
@@ -162,9 +163,6 @@ RETURN_CODE=0
for SCL in "php %{phpunit}" php73 php74 php80; do
if which $SCL; then
set $SCL
- VER=$($1 -r 'echo PHP_VERSION_ID;')
- [ $VER -ge 80000 ] && SKIP="--filter '^((?!(testIntegration)).)*$'"
-
$1 ${2:-%{_bindir}/phpunit9} $SKIP \
--verbose || RETURN_CODE=1
fi
@@ -184,6 +182,10 @@ exit $RETURN_CODE
%changelog
+* Wed Oct 21 2020 Remi Collet <remi@remirepo.net> - 2.14.0-1
+- update to 2.14.0
+- raise dependency on PHP 7.2.5
+
* Tue Aug 11 2020 Remi Collet <remi@remirepo.net> - 2.13.1-1
- update to 2.13.1
- switch to phpunit9