summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-06 12:28:00 +0200
committerRemi Collet <remi@remirepo.net>2020-07-06 12:28:00 +0200
commit8d6d5c2d9e7e53591f991b9fdc49294bada8337f (patch)
tree897df3a592f5323e98de1b98b39c899a8a7f7827
parentbbf9f48f76efe3b885dd7815b7342affcbbf1323 (diff)
update to 2.13.0
raise dependency on PHP 7.1.3 switch to phpunit8
-rw-r--r--composer.json7
-rw-r--r--php-twig2.spec19
2 files changed, 16 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 0d1c0ad..fb474d8 100644
--- a/composer.json
+++ b/composer.json
@@ -5,6 +5,7 @@
"keywords": ["templating"],
"homepage": "https://twig.symfony.com",
"license": "BSD-3-Clause",
+ "minimum-stability": "dev",
"authors": [
{
"name": "Fabien Potencier",
@@ -23,12 +24,12 @@
}
],
"require": {
- "php": "^7.0",
+ "php": ">=7.1.3",
"symfony/polyfill-mbstring": "^1.3",
"symfony/polyfill-ctype": "^1.8"
},
"require-dev": {
- "symfony/phpunit-bridge": "^4.4|^5.0",
+ "symfony/phpunit-bridge": "^4.4.9|^5.0.9",
"psr/container": "^1.0"
},
"autoload": {
@@ -46,7 +47,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.12-dev"
+ "dev-master": "2.13-dev"
}
}
}
diff --git a/php-twig2.spec b/php-twig2.spec
index 0fd5902..323de07 100644
--- a/php-twig2.spec
+++ b/php-twig2.spec
@@ -13,18 +13,18 @@
%global with_tests 0%{!?_without_tests:1}
%global github_owner twigphp
%global github_name Twig
-%global github_commit 18772e0190734944277ee97a02a9a6c6555fcd94
+%global github_commit 46a612ba1bbf6ee1c58acabacd868212ff8a2911
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor twig
%global composer_project twig
-# "php": "^7.0"
-%global php_min_ver 7.0
+# "php": ">=7.1.3"
+%global php_min_ver 7.1.3
%global phpdir %{_datadir}/php
Name: php-%{composer_project}2
-Version: 2.12.5
+Version: 2.13.0
Release: 1%{?dist}
Summary: The flexible, fast, and secure template engine for PHP
@@ -39,7 +39,7 @@ BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
# For tests
BuildRequires: php(language) >= 7.1
-BuildRequires: phpunit7
+BuildRequires: phpunit8
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
@@ -157,9 +157,9 @@ sed -e '/listener/d' phpunit.xml.dist > phpunit.xml
RETURN_CODE=0
: Upstream tests with SCLs if available
-for SCL in php php71 php72 php73 php74; do
+for SCL in php php72 php73 php74 php80; do
if which $SCL; then
- $SCL %{_bindir}/phpunit7 --verbose || RETURN_CODE=1
+ $SCL %{_bindir}/phpunit8 --verbose || RETURN_CODE=1
fi
done
exit $RETURN_CODE
@@ -177,6 +177,11 @@ exit $RETURN_CODE
%changelog
+* Mon Jul 6 2020 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+- raise dependency on PHP 7.1.3
+- switch to phpunit8
+
* Wed Feb 12 2020 Remi Collet <remi@remirepo.net> - 2.12.5-1
- update to 2.12.5