summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-12-18 09:46:10 +0100
committerRemi Collet <remi@remirepo.net>2018-12-18 09:46:10 +0100
commit4243cdf21a024eff79c856733b140276a83f8380 (patch)
treeb242be2dd43a75a41b0559c657535736bb7a9021
parent8af6d3652a869aee1aa87d79096ebcd8da8a722e (diff)
update to 2.6.0
add dependency on symfony/polyfill-mbstring 1.3
-rw-r--r--composer.json6
-rw-r--r--php-twig2.spec24
2 files changed, 24 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index e080955..094e1ce 100644
--- a/composer.json
+++ b/composer.json
@@ -28,11 +28,11 @@
},
"require": {
"php": "^7.0",
- "symfony/polyfill-mbstring": "~1.0",
+ "symfony/polyfill-mbstring": "^1.3",
"symfony/polyfill-ctype": "^1.8"
},
"require-dev": {
- "symfony/phpunit-bridge": "^3.3",
+ "symfony/phpunit-bridge": "^3.4.19|^4.1.8",
"symfony/debug": "^2.7",
"psr/container": "^1.0"
},
@@ -51,7 +51,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.5-dev"
+ "dev-master": "2.6-dev"
}
}
}
diff --git a/php-twig2.spec b/php-twig2.spec
index 68ce6d5..c9af341 100644
--- a/php-twig2.spec
+++ b/php-twig2.spec
@@ -13,7 +13,7 @@
%global with_tests 0%{!?_without_tests:1}
%global github_owner twigphp
%global github_name Twig
-%global github_commit 6a5f676b77a90823c2d4eaf76137b771adf31323
+%global github_commit a11dd39f5b6589e14f0ff3b36675d06047c589b1
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor twig
@@ -24,7 +24,7 @@
%global phpdir %{_datadir}/php
Name: php-%{composer_project}2
-Version: 2.5.0
+Version: 2.6.0
Release: 1%{?dist}
Summary: The flexible, fast, and secure template engine for PHP
@@ -43,11 +43,14 @@ BuildRequires: phpunit6
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(symfony/debug) >= 2.7 with php-composer(symfony/debug) < 3)
BuildRequires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
-# remirepo:5
+BuildRequires: (php-composer(symfony/polyfill-mbstring) >= 1.3 with php-composer(symfony/polyfill-mbstring) < 2)
+# remirepo:7
%else
BuildRequires: php-symfony-debug >= 2.7
BuildRequires: php-composer(psr/container) < 2
BuildRequires: php-composer(psr/container) >= 1.0
+BuildRequires: php-symfony-polyfill < 2
+BuildRequires: php-symfony-polyfill >= 1.3
%endif
# Workaround
BuildRequires: php-symfony-common
@@ -66,6 +69,14 @@ BuildRequires: php-simplexml
## composer.json
Requires: php(language) >= %{php_min_ver}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(symfony/polyfill-mbstring) >= 1.3 with php-composer(symfony/polyfill-mbstring) < 2)
+# remirepo:4
+%else
+Requires: php-symfony-polyfill < 2
+Requires: php-symfony-polyfill >= 1.3
+%endif
## phpcompatinfo (computed from version 2.5.0)
Requires: php-ctype
Requires: php-date
@@ -110,6 +121,9 @@ mv src lib/Twig/psr4
%build
: Create classmap autoloader
phpab --template fedora --output lib/Twig/autoload.php lib/Twig
+cat << 'EOF' | tee -a lib/Twig/autoload.php
+require_once '%{phpdir}/Symfony/Polyfill/autoload.php';
+EOF
%install
@@ -162,6 +176,10 @@ exit $RETURN_CODE
%changelog
+* Tue Dec 18 2018 Remi Collet <remi@remirepo.net> - 2.6.0-1
+- update to 2.6.0
+- add dependency on symfony/polyfill-mbstring 1.3
+
* Fri Jul 13 2018 Remi Collet <remi@remirepo.net> - 2.5.0-1
- update to 2.5.0
- use phpunit6 for test suite