summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-06 12:25:32 +0200
committerRemi Collet <remi@remirepo.net>2020-07-06 12:25:32 +0200
commitdc4b8bcc1b69571b56f155e2a3af28ab51bc4d13 (patch)
treea5134086010eb5a90a2d68fa94dbfc6259b22d89
parentb512acdc26cd5f512c7f44c8a781d755da8f6cdf (diff)
update to 1.43.0
raise dependency on PHP 7.1.3 switch to phpunit8
-rw-r--r--composer.json9
-rw-r--r--php-twig.spec32
2 files changed, 24 insertions, 17 deletions
diff --git a/composer.json b/composer.json
index 9807aa7..d4e096d 100644
--- a/composer.json
+++ b/composer.json
@@ -5,6 +5,7 @@
"keywords": ["templating"],
"homepage": "https://twig.symfony.com",
"license": "BSD-3-Clause",
+ "minimum-stability": "dev",
"authors": [
{
"name": "Fabien Potencier",
@@ -14,7 +15,6 @@
},
{
"name": "Twig Team",
- "homepage": "https://twig.symfony.com/contributors",
"role": "Contributors"
},
{
@@ -24,12 +24,11 @@
}
],
"require": {
- "php": ">=5.5.0",
+ "php": ">=7.1.3",
"symfony/polyfill-ctype": "^1.8"
},
"require-dev": {
- "symfony/phpunit-bridge": "^4.4@dev|^5.0",
- "symfony/debug": "^3.4|^4.2",
+ "symfony/phpunit-bridge": "^4.4.9|^5.0.9",
"psr/container": "^1.0"
},
"autoload": {
@@ -47,7 +46,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "1.42-dev"
+ "dev-master": "1.43-dev"
}
}
}
diff --git a/php-twig.spec b/php-twig.spec
index 4e8a4d4..96437d5 100644
--- a/php-twig.spec
+++ b/php-twig.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-twig
#
-# Copyright (c) 2014-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2014-2020 Shawn Iwinski <shawn.iwinski@gmail.com>
# Remi Collet <remi@fedoraproject.org>
#
# License: MIT
@@ -13,19 +13,19 @@
%global github_owner twigphp
%global github_name Twig
-%global github_version 1.42.4
-%global github_commit e587180584c3d2d6cb864a0454e777bb6dcb6152
+%global github_version 1.43.0
+%global github_commit 597a03e85a60af6feee4f5127f3ef4279a1694c3
%global github_short %(c=%{github_commit}; echo ${c:0:7})
# Lib
%global composer_vendor twig
%global composer_project twig
-# "php": ">=5.5.0"
-%global php_min_ver 5.5
+# "php": ">=7.1.3"
+%global php_min_ver 7.1.3
# Build using "--without tests" to disable tests
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%{!?phpdir: %global phpdir %{_datadir}/php}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
@@ -43,8 +43,8 @@ Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php-devel >= %{php_min_ver}
# Tests
-%if %{with_tests}
-BuildRequires: phpunit7
+%if %{with tests}
+BuildRequires: phpunit8
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(symfony/debug) >= 3.4 with php-composer(symfony/debug) < 4)
BuildRequires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
@@ -145,7 +145,7 @@ cp -rp lib/* %{buildroot}%{phpdir}/
%{_bindir}/php -r 'require_once "%{buildroot}%{phpdir}/Twig/autoload.php";
exit(version_compare("%{version}", Twig\Environment::VERSION, "=") ? 0 : 1);'
-%if %{with_tests}
+%if %{with tests}
: Generate autoloader
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
@@ -158,14 +158,14 @@ require_once '%{buildroot}%{phpdir}/Twig/autoload.php';
));
EOF
-: Disable listener from symfony/phpunit-bridge ^4.4@dev
+: Disable listener from symfony/phpunit-bridge # ^4.4.9|^5.0.9
sed -e '/listener/d' phpunit.xml.dist > phpunit.xml
: Test suite without extension
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit7 \
+ $cmd %{_bindir}/phpunit8 \
--filter '^((?!(testGetAttributeExceptions|testGetAttributeWithTemplateAsObject)).)*$' \
--verbose || ret=1
fi
@@ -186,6 +186,14 @@ exit $ret
%changelog
+* Mon Jul 6 2020 Remi Collet <remi@remirepo.net> - 1.43.0-1
+- update to 1.43.0
+- raise dependency on PHP 7.1.3
+- switch to phpunit8
+
+* Wed Feb 12 2020 Remi Collet <remi@remirepo.net> - 1.42.5-1
+- update to 1.42.5
+
* Tue Nov 12 2019 Remi Collet <remi@remirepo.net> - 1.42.4-1
- update to 1.42.4
- sources from git snapshot