summaryrefslogtreecommitdiffstats
path: root/php-twig-extensions.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-twig-extensions.spec')
-rw-r--r--php-twig-extensions.spec47
1 files changed, 27 insertions, 20 deletions
diff --git a/php-twig-extensions.spec b/php-twig-extensions.spec
index 0a7c64f..dbea697 100644
--- a/php-twig-extensions.spec
+++ b/php-twig-extensions.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-twig-extensions
#
-# Copyright (c) 2014-2017 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2014-2018 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,17 +12,16 @@
%global github_owner twigphp
%global github_name Twig-extensions
-%global github_version 1.5.1
-%global github_commit d188c76168b853481cc75879ea045bf93d718e9c
+%global github_version 1.5.2
+%global github_commit 2c1a86526d0044065220d1b51ac08348bea5ca82
%global composer_vendor twig
%global composer_project extensions
-# "symfony/translation": "~2.3|~3.0"
-# NOTE: Min version not 2.3 because autoloader required
-%global symfony_min_ver %{?el6:2.3.31}%{!?el6:2.7.1}
+# "symfony/translation": "^2.7|^3.4"
+%global symfony_min_ver 2.7.1
%global symfony_max_ver 4.0
-# "twig/twig": "~1.27|~2.0"
+# "twig/twig": "^1.27|^2.0"
%global twig_min_ver 1.27
%global twig_max_ver 3.0
@@ -46,15 +45,16 @@ BuildArch: noarch
%if %{with_tests}
BuildRequires: php-composer(phpunit/phpunit)
## composer.json
-BuildRequires: php-composer(symfony/translation) >= %{symfony_min_ver}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(symfony/translation) >= %{symfony_min_ver} with php-composer(symfony/translation) < %{symfony_max_ver})
+BuildRequires: (php-composer(twig/twig) >= %{twig_min_ver} with php-composer(twig/twig) < %{twig_max_ver})
+%else
BuildRequires: php-composer(symfony/translation) < %{symfony_max_ver}
-BuildRequires: php-composer(twig/twig) >= %{twig_min_ver}
-%if 0%{?fedora} < 25
+BuildRequires: php-composer(symfony/translation) >= %{symfony_min_ver}
BuildRequires: php-composer(twig/twig) < 2
-%else
-BuildRequires: php-composer(twig/twig) < %{twig_max_ver}
+BuildRequires: php-composer(twig/twig) >= %{twig_min_ver}
%endif
-## phpcompatinfo (computed from version 1.5.1)
+## phpcompatinfo (computed from version 1.5.2)
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-date
BuildRequires: php-mbstring
@@ -65,16 +65,18 @@ BuildRequires: php-composer(fedora/autoloader)
%endif
# composer.json
-%if 0%{?fedora} < 25
-Requires: php-composer(twig/twig) < 2
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(twig/twig) >= %{twig_min_ver} with php-composer(twig/twig) < %{twig_max_ver})
+# composer.json: optional
+Requires: (php-composer(symfony/translation) >= %{symfony_min_ver} with php-composer(symfony/translation) < %{symfony_max_ver})
%else
-Requires: php-composer(twig/twig) < %{twig_max_ver}
-%endif
+# v2 to not pull PHP 7
+Requires: php-composer(twig/twig) < 2
Requires: php-composer(twig/twig) >= %{twig_min_ver}
-# composer.json: optional
Requires: php-composer(symfony/translation) >= %{symfony_min_ver}
Requires: php-composer(symfony/translation) < %{symfony_max_ver}
-# phpcompatinfo (computed from version 1.5.1)
+%endif
+# phpcompatinfo (computed from version 1.5.2)
Requires: php(language) >= 5.3.0
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -135,7 +137,7 @@ sed -e 's/testLocalizedDateFilterWithDateTimeZone/SKIPtestLocalizedDateFilterWit
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php55} php56 php70 php71 php72; do
+for PHP_EXEC in "" %{?rhel:php55 php56} php70 php71 php72 php73; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose \
--bootstrap %{buildroot}%{phpdir}/Twig/Extensions/autoload.php \
@@ -158,6 +160,11 @@ exit $RETURN_CODE
%changelog
+* Tue Sep 4 2018 Remi Collet <remi@remirepo.net> - 1.5.2-1
+- update to 1.5.2 (no change)
+- use range dependencies
+- raise dependency on symfony/translation 2.7.1
+
* Sun Jul 09 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.5.1-1
- Update to 1.5.1 (RHBZ #1456812)
- Add max version constraints to BuildRequires