summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-16 15:33:18 +0200
committerRemi Collet <remi@remirepo.net>2018-10-16 15:33:18 +0200
commitfc38cc7d708abed92cfcffd1e1d123f2ad4fe6a5 (patch)
treecf799667e48f637e1660fe87558595c7e1e35d1b
parent65841c9068159035b224d844e8b2f4c0b5d9ef73 (diff)
skip 1 test failing with PHP 7.3 reported as https://github.com/true/php-punycode/issues/29
-rw-r--r--php-true-punycode.spec38
1 files changed, 14 insertions, 24 deletions
diff --git a/php-true-punycode.spec b/php-true-punycode.spec
index a122959..abac06b 100644
--- a/php-true-punycode.spec
+++ b/php-true-punycode.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-true-punycode
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -16,17 +16,15 @@
Name: php-true-punycode
Version: 2.1.1
-Release: 1%{?dist}
+Release: 6%{?dist}
Summary: A Bootstring encoding of Unicode for IDNA
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildArch: noarch
BuildRequires: php(language) >= 5.3
BuildRequires: php-mbstring
BuildRequires: %{_bindir}/phpunit
@@ -61,7 +59,6 @@ Autoloader: %{_datadir}/php/TrueBV/autoload.php
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{_datadir}/php
cp -pr src %{buildroot}%{_datadir}/php/TrueBV
@@ -71,34 +68,23 @@ cp -pr src %{buildroot}%{_datadir}/php/TrueBV
mkdir vendor
ln -s %{buildroot}%{_datadir}/php/TrueBV/autoload.php vendor/autoload.php
+# testEncodeUppercase affected by IDNA2003/2008 changes
: Run test suite
-# remirepo:11
ret=0
-run=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php70 php71 php72 php73; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit \
+ --filter '^((?!(testEncodeUppercase)).)*$' \
+ --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -107,6 +93,10 @@ rm -rf %{buildroot}
%changelog
+* Tue Oct 16 2018 Remi Collet <remi@fedoraproject.org> - 2.1.1-6
+- skip 1 test failing with PHP 7.3 reported as
+ https://github.com/true/php-punycode/issues/29
+
* Wed Nov 16 2016 Remi Collet <remi@fedoraproject.org> - 2.1.1-1
- update to 2.1.1 (no change)
- switch to fedora/autoloader