summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-04-04 12:50:21 +0200
committerRemi Collet <remi@remirepo.net>2019-04-04 12:50:21 +0200
commita9d0d2d70871df0a2f3fbda48f46b7c3602797a2 (patch)
treead051d847f228a021945267e0ae86f2b436e0d10
parent30f9308eea9cad19d8c9a29f57133bde56e531d2 (diff)
update to 1.1.2 (no change)
switch back to phpunit 6 and 7
-rw-r--r--php-theseer-tokenizer.spec26
1 files changed, 13 insertions, 13 deletions
diff --git a/php-theseer-tokenizer.spec b/php-theseer-tokenizer.spec
index 38c80c0..9d37986 100644
--- a/php-theseer-tokenizer.spec
+++ b/php-theseer-tokenizer.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 06b6ce404ee574e9c1787fb67bb9980ca4387c34
+%global gh_commit 1c42705be2b6c1de5904f8afacef5895cab44bf8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor theseer
%global gh_project tokenizer
@@ -14,19 +14,16 @@
%global ns_project Tokenizer
Name: php-%{gh_vendor}-%{gh_project}
-Version: 1.1.1
-Release: 2%{?dist}
+Version: 1.1.2
+Release: 1%{?dist}
Summary: Library for converting tokenized PHP source code into XML
License: BSD
URL: https://github.com/%{gh_vendor}/%{gh_project}
Source0: https://github.com/%{gh_vendor}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
-Patch0: https://patch-diff.githubusercontent.com/raw/theseer/tokenizer/pull/4.patch
-
BuildArch: noarch
-# Because test suite use "void" introduce in 7.1
-BuildRequires: php(language) >= 7.1
+BuildRequires: php(language) >= 7.0
BuildRequires: php-xmlwriter
BuildRequires: php-dom
BuildRequires: php-tokenizer
@@ -36,11 +33,11 @@ BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# Tests
# remirepo:1
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit8
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
# remirepo:3
%else
-%global phpunit %{_bindir}/phpunit7
+%global phpunit %{_bindir}/phpunit6
%endif
BuildRequires: %{phpunit}
@@ -70,7 +67,6 @@ Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .pr4
%build
@@ -85,11 +81,11 @@ cp -pr src %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}
%check
ret=0
-for cmdarg in "php %{phpunit}" "php71 %{_bindir}/phpunit7" php72 php73; do
+for cmdarg in "php %{phpunit}" php71 php72 php73; do
if which $cmdarg; then
set $cmdarg
$1 -d auto_prepend_file=%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php \
- ${2:-%{_bindir}/phpunit8} \
+ ${2:-%{_bindir}/phpunit7} \
--no-coverage --verbose || ret=1
fi
done
@@ -106,6 +102,10 @@ exit $ret
%changelog
+* Thu Apr 4 2019 Remi Collet <remi@remirepo.net> - 1.1.2-1
+- update to 1.1.2 (no change)
+- switch back to phpunit 6 and 7
+
* Thu Apr 4 2019 Remi Collet <remi@remirepo.net> - 1.1.1-2
- add patch from https://github.com/theseer/tokenizer/pull/4
and use phpunit7 with 7.1