summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-13 11:51:11 +0200
committerRemi Collet <remi@remirepo.net>2020-07-13 11:51:11 +0200
commit4ab7437b184e8ca1bb3271a28a535006d177ecf9 (patch)
treeff7b4b3397a713fa6d0b2fa0aa37184c40de0e4d
parentefe7b7291cab06fe54983aee51852e6fb8a9ef73 (diff)
update to 1.2.0
sources from git snapshot
-rw-r--r--composer.json2
-rw-r--r--php-theseer-tokenizer.spec21
2 files changed, 11 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 2870c70..3f452a9 100644
--- a/composer.json
+++ b/composer.json
@@ -13,7 +13,7 @@
"issues": "https://github.com/theseer/tokenizer/issues"
},
"require": {
- "php": "^7.0",
+ "php": "^7.2 || ^8.0",
"ext-xmlwriter": "*",
"ext-dom": "*",
"ext-tokenizer": "*"
diff --git a/php-theseer-tokenizer.spec b/php-theseer-tokenizer.spec
index 958c292..7b9ec0a 100644
--- a/php-theseer-tokenizer.spec
+++ b/php-theseer-tokenizer.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 11336f6f84e16a720dae9d8e6ed5019efa85a0f9
+%global gh_commit 75a63c33a8577608444246075ea0af0d052e452a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor theseer
%global gh_project tokenizer
@@ -14,13 +14,14 @@
%global ns_project Tokenizer
Name: php-%{gh_vendor}-%{gh_project}
-Version: 1.1.3
+Version: 1.2.0
Release: 1%{?dist}
Summary: Library for converting tokenized PHP source code into XML
License: BSD
URL: https://github.com/%{gh_vendor}/%{gh_project}
-Source0: https://github.com/%{gh_vendor}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
+Source0: %{name}-%{version}-%{?gh_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.0
@@ -32,17 +33,11 @@ BuildRequires: php-spl
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# Tests
-# remirepo:1
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit7
-# remirepo:3
-%else
-%global phpunit %{_bindir}/phpunit6
-%endif
BuildRequires: %{phpunit}
# From composer.json, "require": {
-# "php": "^7.0",
+# "php": "^7.0 || ^8.0",
# "ext-xmlwriter": "*",
# "ext-dom": "*",
# "ext-tokenizer": "*"
@@ -81,7 +76,7 @@ cp -pr src %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}
%check
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
$1 -d auto_prepend_file=%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php \
@@ -102,6 +97,10 @@ exit $ret
%changelog
+* Mon Jul 13 2020 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+- sources from git snapshot
+
* Fri Jun 14 2019 Remi Collet <remi@remirepo.net> - 1.1.3-1
- update to 1.1.3