summaryrefslogtreecommitdiffstats
path: root/php-theseer-fDOMDocument.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-14 06:44:52 +0200
committerRemi Collet <remi@remirepo.net>2017-04-14 06:44:52 +0200
commit5caa626d0d1458a68397ee5cdaacc5c87fba200c (patch)
tree6d7e8203041cace2967991661d1dc1c1132a3af7 /php-theseer-fDOMDocument.spec
parentbc050325f95f06054fa86f3fd6563728725c577b (diff)
v1.6.2
Diffstat (limited to 'php-theseer-fDOMDocument.spec')
-rw-r--r--php-theseer-fDOMDocument.spec36
1 files changed, 24 insertions, 12 deletions
diff --git a/php-theseer-fDOMDocument.spec b/php-theseer-fDOMDocument.spec
index 9d0bd4d..9f2be20 100644
--- a/php-theseer-fDOMDocument.spec
+++ b/php-theseer-fDOMDocument.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit d9ad139d6c2e8edf5e313ffbe37ff13344cf0684
+%global gh_commit 1dbe93a2c98fe57d0dd9792c373ec75c21f70750
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner theseer
%global gh_project fDOMDocument
@@ -16,7 +16,7 @@
%global pear_channel pear.netpirates.net
Name: php-theseer-fDOMDocument
-Version: 1.6.1
+Version: 1.6.2
Release: 1%{?dist}
Summary: An Extension to PHP standard DOM
@@ -25,11 +25,17 @@ License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Patch0: %{name}-pr29.patch
+
BuildArch: noarch
BuildRequires: php(language) >= 5.3.3
# For test
-BuildRequires: %{_bindir}/phpunit
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php-dom
BuildRequires: php-libxml
@@ -55,6 +61,7 @@ and exceptions by default
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
%build
@@ -62,17 +69,19 @@ and exceptions by default
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{php_home}
cp -pr src %{buildroot}%{php_home}/%{gh_project}
%check
-phpunit
-
-
-%clean
-rm -rf %{buildroot}
+ret=0
+for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmd; then
+ set $cmd
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ fi
+done
+exit $ret
%post
@@ -83,7 +92,6 @@ fi
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.md composer.json
@@ -91,6 +99,10 @@ fi
%changelog
+* Fri Apr 14 2017 Remi Collet <remi@remirepo.net> - 1.6.2-1
+- Update to 1.6.2
+- use phpunit6 when available
+
* Thu May 28 2015 Remi Collet <remi@fedoraproject.org> - 1.6.1-1
- Update to 1.6.1
@@ -122,4 +134,4 @@ fi
* Thu Oct 11 2012 Remi Collet <remi@fedoraproject.org> - 1.3.1-1
- Version 1.3.1 (stable) - API 1.3.0 (stable)
-- Initial packaging \ No newline at end of file
+- Initial packaging