summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-14 13:07:11 +0200
committerRemi Collet <remi@remirepo.net>2017-04-14 13:07:11 +0200
commit1c769f7ccb068b27104669405569a781cdcba692 (patch)
treeb96729383b9641f292eb4fe8a39b8ab2f466bbb6
parent8ec7121ce7809a65c14c193c1675aa7f244d8126 (diff)
v1.6.3
-rw-r--r--composer.json3
-rw-r--r--php-theseer-fDOMDocument-pr29.patch116
-rw-r--r--php-theseer-fDOMDocument.spec11
3 files changed, 8 insertions, 122 deletions
diff --git a/composer.json b/composer.json
index cd88df3..ad9d3db 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,8 @@
"require": {
"php": ">=5.3.3",
"ext-dom": "*",
- "lib-libxml": "*"
+ "lib-libxml": "*",
+ "phpunit/phpunit": "^4.8.35|^5.6|^6.0"
},
"autoload": {
"classmap": [
diff --git a/php-theseer-fDOMDocument-pr29.patch b/php-theseer-fDOMDocument-pr29.patch
deleted file mode 100644
index aa245ec..0000000
--- a/php-theseer-fDOMDocument-pr29.patch
+++ /dev/null
@@ -1,116 +0,0 @@
-From 419398ed434bb240487c42628a4bd30d6795ae81 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 14 Apr 2017 06:33:53 +0200
-Subject: [PATCH 1/2] fix (PHP 7.2) count(): Parameter must be an array or an
- object that implements Countable
-
----
- src/XPathQuery.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/XPathQuery.php b/src/XPathQuery.php
-index ab7e3a9..cd661ad 100644
---- a/src/XPathQuery.php
-+++ b/src/XPathQuery.php
-@@ -191,7 +191,7 @@ private function getXPathObjectFor(\DOMNode $ctx) {
- */
- private function buildQuery(fDOMXPath $xp, array $values = NULL) {
- $backup = $this->values;
-- if (count($values) > 0) {
-+ if (is_array($values) && count($values) > 0) {
- foreach($values as $k => $v) {
- $this->bind($k, $v);
- }
-
-From c8069cbd0032a476a04c9147e89c8c015a7dd5de Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 14 Apr 2017 06:34:06 +0200
-Subject: [PATCH 2/2] allow modern PHPUnit
-
----
- tests/Translator.test.php | 2 +-
- tests/XPathQuery.test.php | 2 +-
- tests/fDOMDocument.test.php | 2 +-
- tests/fDOMDocumentFragment.test.php | 2 +-
- tests/fDOMElement.test.php | 2 +-
- tests/fDOMXPath.test.php | 2 +-
- 6 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/tests/Translator.test.php b/tests/Translator.test.php
-index 2152238..0c10cb1 100644
---- a/tests/Translator.test.php
-+++ b/tests/Translator.test.php
-@@ -4,7 +4,7 @@
-
- use TheSeer\fDOM\CSS\Translator;
-
-- class TranslatorTest extends \PHPUnit_Framework_TestCase {
-+ class TranslatorTest extends \PHPUnit\Framework\TestCase {
-
- /**
- * @dataProvider provider
-diff --git a/tests/XPathQuery.test.php b/tests/XPathQuery.test.php
-index fb0aeae..3bed435 100644
---- a/tests/XPathQuery.test.php
-+++ b/tests/XPathQuery.test.php
-@@ -44,7 +44,7 @@
- use TheSeer\fDOM\XPathQuery;
- use TheSeer\fDOM\fDOMDocument;
-
-- class XPathQueryTest extends \PHPUnit_Framework_TestCase {
-+ class XPathQueryTest extends \PHPUnit\Framework\TestCase {
-
- private $dom;
-
-diff --git a/tests/fDOMDocument.test.php b/tests/fDOMDocument.test.php
-index b7392d8..fd5c08f 100644
---- a/tests/fDOMDocument.test.php
-+++ b/tests/fDOMDocument.test.php
-@@ -48,7 +48,7 @@
- * @author Arne Blankerts <arne@blankerts.de>
- * @copyright Arne Blankerts <arne@blankerts.de>, All rights reserved.
- */
-- class fDOMDocumentTest extends \PHPUnit_Framework_TestCase {
-+ class fDOMDocumentTest extends \PHPUnit\Framework\TestCase {
-
- /**
- * @var fDOMDocument
-diff --git a/tests/fDOMDocumentFragment.test.php b/tests/fDOMDocumentFragment.test.php
-index 1f2fcf3..d524bfe 100644
---- a/tests/fDOMDocumentFragment.test.php
-+++ b/tests/fDOMDocumentFragment.test.php
-@@ -49,7 +49,7 @@
- * @author Arne Blankerts <arne@blankerts.de>
- * @copyright Arne Blankerts <arne@blankerts.de>, All rights reserved.
- */
-- class fDOMDocumentFragmentTest extends \PHPUnit_Framework_TestCase {
-+ class fDOMDocumentFragmentTest extends \PHPUnit\Framework\TestCase {
-
- /**
- * @var fDOMDocument
-diff --git a/tests/fDOMElement.test.php b/tests/fDOMElement.test.php
-index b7ae9b3..0e6a11c 100644
---- a/tests/fDOMElement.test.php
-+++ b/tests/fDOMElement.test.php
-@@ -49,7 +49,7 @@
- * @author Arne Blankerts <arne@blankerts.de>
- * @copyright Arne Blankerts <arne@blankerts.de>, All rights reserved.
- */
-- class fDOMElementTest extends \PHPUnit_Framework_TestCase {
-+ class fDOMElementTest extends \PHPUnit\Framework\TestCase {
-
- /**
- * @var fDOMDocument
-diff --git a/tests/fDOMXPath.test.php b/tests/fDOMXPath.test.php
-index ce91e13..2504a75 100644
---- a/tests/fDOMXPath.test.php
-+++ b/tests/fDOMXPath.test.php
-@@ -49,7 +49,7 @@
- * @author Arne Blankerts <arne@blankerts.de>
- * @copyright Arne Blankerts <arne@blankerts.de>, All rights reserved.
- */
-- class fDOMXPathTest extends \PHPUnit_Framework_TestCase {
-+ class fDOMXPathTest extends \PHPUnit\Framework\TestCase {
-
- /**
- * @var TheSeer\fDOM\fDOMDocument
diff --git a/php-theseer-fDOMDocument.spec b/php-theseer-fDOMDocument.spec
index 3dfed11..c6449a6 100644
--- a/php-theseer-fDOMDocument.spec
+++ b/php-theseer-fDOMDocument.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit 1dbe93a2c98fe57d0dd9792c373ec75c21f70750
+%global gh_commit 07aa549924fa5d12fbf7c08401931363558e4523
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner theseer
%global gh_project fDOMDocument
@@ -16,7 +16,7 @@
%global pear_channel pear.netpirates.net
Name: php-theseer-fDOMDocument
-Version: 1.6.2
+Version: 1.6.3
Release: 1%{?dist}
Summary: An Extension to PHP standard DOM
@@ -25,8 +25,6 @@ License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-Patch0: %{name}-pr29.patch
-
BuildArch: noarch
BuildRequires: php(language) >= 5.3.3
# For test
@@ -61,7 +59,6 @@ and exceptions by default
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
%build
@@ -99,6 +96,10 @@ fi
%changelog
+* Fri Apr 14 2017 Remi Collet <remi@remirepo.net> - 1.6.3-1
+- Update to 1.6.3
+- drop patch merged upstream
+
* Fri Apr 14 2017 Remi Collet <remi@remirepo.net> - 1.6.2-1
- Update to 1.6.2
- use phpunit6 when available