summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-06 15:18:29 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-06 15:18:29 +0200
commitb625017a314c9c2fd06865367eb702ee7103d1d2 (patch)
tree8a3aaea387a0044bf041450eb919510230645b1b
php-theseer-directoryscanner: 1.3.0 - NEW package
-rw-r--r--Makefile4
-rw-r--r--php-theseer-directoryscanner.spec97
2 files changed, 101 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-theseer-directoryscanner.spec b/php-theseer-directoryscanner.spec
new file mode 100644
index 0000000..97da4e4
--- /dev/null
+++ b/php-theseer-directoryscanner.spec
@@ -0,0 +1,97 @@
+# spec file for php-theseer-directoryscanner
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %global __pear %{_bindir}/pear}
+%global pear_name DirectoryScanner
+%global pear_channel pear.netpirates.net
+
+Name: php-theseer-directoryscanner
+Version: 1.3.0
+Release: 1%{?dist}
+Summary: A recursive directory scanner and filter
+
+Group: Development/Libraries
+# https://github.com/theseer/DirectoryScanner/issues/3
+License: BSD
+URL: https://github.com/theseer/DirectoryScanner
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.1
+BuildRequires: php-pear(PEAR)
+BuildRequires: php-channel(%{pear_channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+# From package.xml
+Requires: php(language) >= 5.3.1
+Requires: php-fileinfo
+Requires: php-spl
+Requires: php-pear(PEAR)
+Requires: php-channel(%{pear_channel})
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+A recursive directory scanner and filter.
+
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%{pear_xmldir}/%{name}.xml
+%dir %{pear_phpdir}/TheSeer
+%{pear_phpdir}/TheSeer/%{pear_name}
+
+
+%changelog
+* Sun Apr 6 2014 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
+- initial package, version 1.3.0 \ No newline at end of file