summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Autoload-php53.patch22
-rw-r--r--php-theseer-autoload.spec13
2 files changed, 7 insertions, 28 deletions
diff --git a/Autoload-php53.patch b/Autoload-php53.patch
deleted file mode 100644
index 0ce1961..0000000
--- a/Autoload-php53.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From d8f950ded329f8a8715b8cbe114cd9c1123e0126 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 24 Apr 2019 13:58:37 +0200
-Subject: [PATCH] restore PHP 5.3 compatibility
-
----
- src/Application.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/Application.php b/src/Application.php
-index 4d883ba..9f14aa6 100644
---- a/src/Application.php
-+++ b/src/Application.php
-@@ -86,7 +86,7 @@ private function runCollector() {
- unset($scanner);
- } else {
- $file = new \SplFileInfo($directory);
-- $filter = $this->factory->getFilter(new \ArrayIterator([$file]));
-+ $filter = $this->factory->getFilter(new \ArrayIterator(array($file)));
- foreach($filter as $file) {
- $this->logger->log('Scanning file ' . $file . "\n");
- $collector->processFile($file);
diff --git a/php-theseer-autoload.spec b/php-theseer-autoload.spec
index 7682fe8..a76edb5 100644
--- a/php-theseer-autoload.spec
+++ b/php-theseer-autoload.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 6a84b4e077f78be4d0cabff55493ce5823a273cf
+%global gh_commit 9f181597e8c0371f364cfe39d21c24a2e1439ef4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner theseer
%global gh_project Autoload
@@ -19,8 +19,8 @@
%global pear_channel pear.netpirates.net
Name: php-theseer-autoload
-Version: 1.25.4
-Release: 2%{?dist}
+Version: 1.25.5
+Release: 1%{?dist}
Summary: A tool and library to generate autoload code
License: BSD
@@ -29,8 +29,6 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Autoloader path
Patch0: %{gh_project}-rpm.patch
-# PHP 5.3
-Patch1: %{gh_project}-php53.patch
BuildArch: noarch
BuildRequires: php(language) >= 5.3.1
@@ -87,7 +85,6 @@ the option of creating static require lists as well as phar archives.
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p0 -b .rpm
-%patch1 -p1
: drop composer dependencies
sed -e '\:../vendor/:d' -i src/autoload.php
@@ -154,6 +151,10 @@ fi
%changelog
+* Thu Apr 25 2019 Remi Collet <remi@remirepo.net> - 1.25.5-1
+- update to 1.25.5
+- drop patch merged upstream
+
* Wed Apr 24 2019 Remi Collet <remi@remirepo.net> - 1.25.4-2
- add patch for PHP 5.3 from
https://github.com/theseer/Autoload/pull/86