summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Autoload-rpm.patch6
-rw-r--r--composer.json1
-rw-r--r--php-theseer-autoload.spec14
3 files changed, 15 insertions, 6 deletions
diff --git a/Autoload-rpm.patch b/Autoload-rpm.patch
index 0856847..354734a 100644
--- a/Autoload-rpm.patch
+++ b/Autoload-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpab.php.rpm ./phpab.php
---- ./phpab.php.rpm 2023-06-14 08:18:08.257333519 +0200
-+++ ./phpab.php 2023-06-14 08:20:04.223300301 +0200
+--- ./phpab.php.rpm 2023-09-19 09:19:53.895163447 +0200
++++ ./phpab.php 2023-09-19 09:20:45.772936697 +0200
@@ -43,12 +43,12 @@
* 5 - Duplicates found Error
*/
@@ -15,4 +15,4 @@ diff -up ./phpab.php.rpm ./phpab.php
+require '/usr/share/php/TheSeer/Autoload/autoload.php';
$factory = new \TheSeer\Autoload\Factory();
- $factory->getCLI()->run($_SERVER);
+ $rc = $factory->getCLI()->run($_SERVER);
diff --git a/composer.json b/composer.json
index 5d8e95f..ac4494c 100644
--- a/composer.json
+++ b/composer.json
@@ -3,6 +3,7 @@
"description": "A tool and library to generate autoload code.",
"require": {
"php": ">=5.3",
+ "ext-openssl": "*",
"theseer/directoryscanner": "^1.3.3",
"zetacomponents/console-tools": "^1.7"
},
diff --git a/php-theseer-autoload.spec b/php-theseer-autoload.spec
index 0c4a6cc..0fff4ae 100644
--- a/php-theseer-autoload.spec
+++ b/php-theseer-autoload.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 177e95d09f546f4dd44666e60ecdd868d0c24904
+%global gh_commit abb83aaae55eacb3582e1a888a6f74ff14a331d7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner theseer
%global gh_project Autoload
@@ -25,7 +25,7 @@
%endif
Name: php-theseer-autoload
-Version: 1.28.0
+Version: 1.29.1
Release: 1%{?dist}
Summary: A tool and library to generate autoload code
@@ -58,9 +58,12 @@ BuildRequires: %{phpunit}
%endif
# From composer.json, "require": {
+# "php": ">=5.3",
+# "ext-openssl": "*",
# "theseer/directoryscanner": "^1.3.3",
# "zetacomponents/console-tools": "^1.7.2"
Requires: php(language) >= 5.3.1
+Requires: php-openssl
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(theseer/directoryscanner) >= 1.3.2 with php-composer(theseer/directoryscanner) < 2)
Requires: (php-composer(zetacomponents/console-tools) >= 1.7 with php-composer(zetacomponents/console-tools) < 2)
@@ -72,7 +75,6 @@ Requires: php-zetacomponents-console-tools >= 1.7
Requires: php-cli
Requires: php-date
Requires: php-json
-Requires: php-openssl
Requires: php-phar
Requires: php-spl
Requires: php-tokenizer
@@ -159,6 +161,12 @@ fi
%changelog
+* Thu May 2 2024 Remi Collet <remi@remirepo.net> - 1.29.1-1
+- update to 1.29.1
+
+* Tue Sep 19 2023 Remi Collet <remi@remirepo.net> - 1.29.0-1
+- update to 1.29.0
+
* Wed Jun 14 2023 Remi Collet <remi@remirepo.net> - 1.28.0-1
- update to 1.28.0