summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Autoload-rpm.patch7
-rw-r--r--composer.json1
-rw-r--r--php-theseer-autoload.spec23
3 files changed, 22 insertions, 9 deletions
diff --git a/Autoload-rpm.patch b/Autoload-rpm.patch
index bd699c1..354734a 100644
--- a/Autoload-rpm.patch
+++ b/Autoload-rpm.patch
@@ -1,5 +1,6 @@
---- phpab.php.rpm 2015-06-30 22:02:53.000000000 +0200
-+++ phpab.php 2015-07-01 10:13:32.443481551 +0200
+diff -up ./phpab.php.rpm ./phpab.php
+--- ./phpab.php.rpm 2023-09-19 09:19:53.895163447 +0200
++++ ./phpab.php 2023-09-19 09:20:45.772936697 +0200
@@ -43,12 +43,12 @@
* 5 - Duplicates found Error
*/
@@ -14,4 +15,4 @@
+require '/usr/share/php/TheSeer/Autoload/autoload.php';
$factory = new \TheSeer\Autoload\Factory();
- $factory->getCLI()->run();
+ $rc = $factory->getCLI()->run($_SERVER);
diff --git a/composer.json b/composer.json
index 5d8e95f..ac4494c 100644
--- a/composer.json
+++ b/composer.json
@@ -3,6 +3,7 @@
"description": "A tool and library to generate autoload code.",
"require": {
"php": ">=5.3",
+ "ext-openssl": "*",
"theseer/directoryscanner": "^1.3.3",
"zetacomponents/console-tools": "^1.7"
},
diff --git a/php-theseer-autoload.spec b/php-theseer-autoload.spec
index 07b0f3c..0fff4ae 100644
--- a/php-theseer-autoload.spec
+++ b/php-theseer-autoload.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 39eb04ee16634af2110c646a224c81b1f04bcf1f
+%global gh_commit abb83aaae55eacb3582e1a888a6f74ff14a331d7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner theseer
%global gh_project Autoload
@@ -25,7 +25,7 @@
%endif
Name: php-theseer-autoload
-Version: 1.27.2
+Version: 1.29.1
Release: 1%{?dist}
Summary: A tool and library to generate autoload code
@@ -37,7 +37,7 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
Patch0: %{gh_project}-rpm.patch
BuildArch: noarch
-BuildRequires: php(language) >= 7.2
+BuildRequires: php(language) >= 7.4
BuildRequires: php-cli
BuildRequires: php-date
BuildRequires: php-json
@@ -58,9 +58,12 @@ BuildRequires: %{phpunit}
%endif
# From composer.json, "require": {
+# "php": ">=5.3",
+# "ext-openssl": "*",
# "theseer/directoryscanner": "^1.3.3",
# "zetacomponents/console-tools": "^1.7.2"
Requires: php(language) >= 5.3.1
+Requires: php-openssl
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(theseer/directoryscanner) >= 1.3.2 with php-composer(theseer/directoryscanner) < 2)
Requires: (php-composer(zetacomponents/console-tools) >= 1.7 with php-composer(zetacomponents/console-tools) < 2)
@@ -72,7 +75,6 @@ Requires: php-zetacomponents-console-tools >= 1.7
Requires: php-cli
Requires: php-date
Requires: php-json
-Requires: php-openssl
Requires: php-phar
Requires: php-spl
Requires: php-tokenizer
@@ -91,7 +93,7 @@ the option of creating static require lists as well as phar archives.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p0 -b .rpm
+%patch -P0 -p0 -b .rpm
: drop composer dependencies
sed -e '\:../vendor/:d' -i src/autoload.php
@@ -133,7 +135,7 @@ require '%{buildroot}%{_datadir}/php/TheSeer/Autoload/autoload.php';
EOF
ret=0
-for cmd in "php %{phpunit}" php80 php81 php82; do
+for cmd in "php %{phpunit}" php80 php81 php82 php83; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -159,6 +161,15 @@ fi
%changelog
+* Thu May 2 2024 Remi Collet <remi@remirepo.net> - 1.29.1-1
+- update to 1.29.1
+
+* Tue Sep 19 2023 Remi Collet <remi@remirepo.net> - 1.29.0-1
+- update to 1.29.0
+
+* Wed Jun 14 2023 Remi Collet <remi@remirepo.net> - 1.28.0-1
+- update to 1.28.0
+
* Fri Feb 17 2023 Remi Collet <remi@remirepo.net> - 1.27.2-1
- update to 1.27.2