summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Autoload-rpm.patch7
-rw-r--r--php-theseer-autoload.spec13
2 files changed, 12 insertions, 8 deletions
diff --git a/Autoload-rpm.patch b/Autoload-rpm.patch
index bd699c1..0856847 100644
--- a/Autoload-rpm.patch
+++ b/Autoload-rpm.patch
@@ -1,5 +1,6 @@
---- phpab.php.rpm 2015-06-30 22:02:53.000000000 +0200
-+++ phpab.php 2015-07-01 10:13:32.443481551 +0200
+diff -up ./phpab.php.rpm ./phpab.php
+--- ./phpab.php.rpm 2023-06-14 08:18:08.257333519 +0200
++++ ./phpab.php 2023-06-14 08:20:04.223300301 +0200
@@ -43,12 +43,12 @@
* 5 - Duplicates found Error
*/
@@ -14,4 +15,4 @@
+require '/usr/share/php/TheSeer/Autoload/autoload.php';
$factory = new \TheSeer\Autoload\Factory();
- $factory->getCLI()->run();
+ $factory->getCLI()->run($_SERVER);
diff --git a/php-theseer-autoload.spec b/php-theseer-autoload.spec
index 07b0f3c..0c4a6cc 100644
--- a/php-theseer-autoload.spec
+++ b/php-theseer-autoload.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 39eb04ee16634af2110c646a224c81b1f04bcf1f
+%global gh_commit 177e95d09f546f4dd44666e60ecdd868d0c24904
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner theseer
%global gh_project Autoload
@@ -25,7 +25,7 @@
%endif
Name: php-theseer-autoload
-Version: 1.27.2
+Version: 1.28.0
Release: 1%{?dist}
Summary: A tool and library to generate autoload code
@@ -37,7 +37,7 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
Patch0: %{gh_project}-rpm.patch
BuildArch: noarch
-BuildRequires: php(language) >= 7.2
+BuildRequires: php(language) >= 7.4
BuildRequires: php-cli
BuildRequires: php-date
BuildRequires: php-json
@@ -91,7 +91,7 @@ the option of creating static require lists as well as phar archives.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p0 -b .rpm
+%patch -P0 -p0 -b .rpm
: drop composer dependencies
sed -e '\:../vendor/:d' -i src/autoload.php
@@ -133,7 +133,7 @@ require '%{buildroot}%{_datadir}/php/TheSeer/Autoload/autoload.php';
EOF
ret=0
-for cmd in "php %{phpunit}" php80 php81 php82; do
+for cmd in "php %{phpunit}" php80 php81 php82 php83; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -159,6 +159,9 @@ fi
%changelog
+* Wed Jun 14 2023 Remi Collet <remi@remirepo.net> - 1.28.0-1
+- update to 1.28.0
+
* Fri Feb 17 2023 Remi Collet <remi@remirepo.net> - 1.27.2-1
- update to 1.27.2