summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-08-13 12:24:08 +0200
committerRemi Collet <fedora@famillecollet.com>2016-08-13 12:24:08 +0200
commitf48e6674fb919797002214f5d7979bec0b734188 (patch)
tree8597fb9a69a82497627a4df971f2fc66f367cd6a
parent332e5f1f9dad8ed33c566cd84cb9104a4e3ad3c5 (diff)
php-theseer-autoload: 1.22.0
-rw-r--r--composer.json28
-rw-r--r--php-theseer-autoload.spec30
2 files changed, 51 insertions, 7 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..e92ada0
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,28 @@
+{
+ "name": "theseer/autoload",
+ "description": "A tool and library to generate autoload code.",
+ "require": {
+ "theseer/directoryscanner": "~1.3",
+ "zetacomponents/console-tools": "~1.7"
+ },
+ "require-dev": {
+ "php": ">=5.3",
+ "phpunit/phpunit": "~4.0|~5.0",
+ "squizlabs/php_codesniffer": "~1.5"
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "license": "BSD License",
+ "authors": [
+ {
+ "name": "Arne Blankerts",
+ "email": "arne@blankerts.de"
+ }
+ ],
+ "bin": [
+ "composer/bin/phpab"
+ ]
+}
diff --git a/php-theseer-autoload.spec b/php-theseer-autoload.spec
index d1105f1..39e7bf4 100644
--- a/php-theseer-autoload.spec
+++ b/php-theseer-autoload.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 19513be5913ed780836e3df5e68bfb5655630612
+%global gh_commit b0b4c214ec5a76ddda0a5964ced3e8f18be2ff8f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner theseer
%global gh_project Autoload
@@ -15,7 +15,7 @@
%global pear_channel pear.netpirates.net
Name: php-theseer-autoload
-Version: 1.21.0
+Version: 1.22.0
Release: 1%{?dist}
Summary: A tool and library to generate autoload code
@@ -105,12 +105,25 @@ cat <<EOF | tee tests/init.php
require '%{buildroot}%{_datadir}/php/TheSeer/Autoload/autoload.php';
EOF
+# remirepo:13
+run=0
+ret=0
+if which php56; then
+ : Run upstream test suite with PHP 5
+ php56 %{_bindir}/phpunit || ret=1
+ run=1
+fi
+if which php71; then
+ : Run upstream test suite with PHP 7
+ php71 %{_bindir}/phpunit || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
: Run upstream test suite
-phpunit --verbose
-
-if which php70; then
- php70 %{_bindir}/phpunit --verbose
+%{_bindir}/phpunit --verbose
+# remirepo:2
fi
+exit $ret
%clean
@@ -134,6 +147,9 @@ fi
%changelog
+* Sat Aug 13 2016 Remi Collet <remi@fedoraproject.org> - 1.22.0-1
+- update to 1.22.0
+
* Wed Nov 11 2015 Remi Collet <remi@fedoraproject.org> - 1.21.0-1
- update to 1.21.0
@@ -195,4 +211,4 @@ fi
- Update to 1.14.2
* Sun Apr 6 2014 Remi Collet <remi@fedoraproject.org> - 1.14.1-1
-- initial package, version 1.14.1 \ No newline at end of file
+- initial package, version 1.14.1