summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-26 09:11:27 +0200
committerRemi Collet <remi@remirepo.net>2017-06-26 09:11:27 +0200
commit76f0dbe57e62b9de4a7abb1d45f3df0f72ab9f85 (patch)
tree5f6c01004501f879bf6982af4b2342f88807c36b
parentd732a696a2d0fe28d9b2697f39fc5c29058b4b4b (diff)
patch for 5.3
-rw-r--r--Autoload-pr78.patch36
-rw-r--r--php-theseer-autoload.spec6
2 files changed, 42 insertions, 0 deletions
diff --git a/Autoload-pr78.patch b/Autoload-pr78.patch
new file mode 100644
index 0000000..979ab0a
--- /dev/null
+++ b/Autoload-pr78.patch
@@ -0,0 +1,36 @@
+From ff3e1ccdca5792de7a1aed654272f04bffe833ba Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 26 Jun 2017 09:04:17 +0200
+Subject: [PATCH] restore PHP 5.3 compatibility
+
+---
+ src/CollectorResult.php | 2 +-
+ tests/DuplicateDetectionTest.php | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/CollectorResult.php b/src/CollectorResult.php
+index 9556767..3538140 100644
+--- a/src/CollectorResult.php
++++ b/src/CollectorResult.php
+@@ -44,7 +44,7 @@ public function addParseResult(\SplFileInfo $file, ParseResult $result) {
+ }
+ if (isset($this->units[$unit])) {
+ if (!isset($this->duplicates[$unit])) {
+- $this->duplicates[$unit] = [ $this->units[$unit] ];
++ $this->duplicates[$unit] = array( $this->units[$unit] );
+ }
+ $this->duplicates[$unit][] = $filename;
+ continue;
+diff --git a/tests/DuplicateDetectionTest.php b/tests/DuplicateDetectionTest.php
+index cf88701..4b02da1 100644
+--- a/tests/DuplicateDetectionTest.php
++++ b/tests/DuplicateDetectionTest.php
+@@ -43,7 +43,7 @@
+ class DuplicateDetectionTest extends \PHPUnit\Framework\TestCase {
+
+ public function testBugIsFixed() {
+- $config = new Config([]);
++ $config = new Config(array());
+ $config->setLowercaseMode(true);
+
+ $factory = new Factory();
diff --git a/php-theseer-autoload.spec b/php-theseer-autoload.spec
index e9db493..f68a604 100644
--- a/php-theseer-autoload.spec
+++ b/php-theseer-autoload.spec
@@ -26,6 +26,8 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Autoloader path
Patch0: %{gh_project}-rpm.patch
+# PHP 5.3
+Patch1: %{gh_project}-pr78.patch
BuildArch: noarch
BuildRequires: php(language) >= 5.3.1
@@ -74,6 +76,7 @@ the option of creating static require lists as well as phar archives.
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p0 -b .rpm
+%patch1 -p1
: drop composer dependencies
sed -e '\:../vendor/:d' -i src/autoload.php
@@ -106,6 +109,7 @@ install -Dpm 0755 phpab.php %{buildroot}%{_bindir}/phpab
cat <<EOF | tee tests/init.php
<?php
require '%{buildroot}%{_datadir}/php/TheSeer/Autoload/autoload.php';
+class_exists('PHPUnit\Framework\TestCase') or class_alias('PHPUnit_Framework_TestCase', 'PHPUnit\Framework\TestCase');
EOF
ret=0
@@ -137,6 +141,8 @@ fi
* Mon Jun 26 2017 Remi Collet <remi@remirepo.net> - 1.24.0-1
- Update to 1.24.0
- use phpunit6 on F26+
+- add patch for PHP 5.3 in EL-6 from
+ https://github.com/theseer/Autoload/pull/78
* Wed Dec 21 2016 Remi Collet <remi@fedoraproject.org> - 1.23.0-1
- update to 1.23.0