summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-03-06 11:18:57 +0100
committerRemi Collet <remi@php.net>2023-03-06 11:18:57 +0100
commitcc5bf12256215df1df894a5e3048228af49b29c1 (patch)
tree79d6fb3d5af00fd45610d450f473feebcd9d8aeb
parent63c013c25eeace1ae592a0e2723970c43728dcba (diff)
update to 1.6.1
-rw-r--r--composer.json17
-rw-r--r--php-tedivm-jshrink.spec34
2 files changed, 29 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index bda07fc..153291a 100644
--- a/composer.json
+++ b/composer.json
@@ -1,7 +1,10 @@
{
"name": "tedivm/jshrink",
"description": "Javascript Minifier built in PHP",
- "keywords": ["minifier","javascript"],
+ "keywords": [
+ "minifier",
+ "javascript"
+ ],
"homepage": "http://github.com/tedious/JShrink",
"type": "library",
"license": "BSD-3-Clause",
@@ -12,14 +15,16 @@
}
],
"require": {
- "php": "^5.6|^7.0|^8.0"
+ "php": "^8.0"
},
"require-dev": {
- "phpunit/phpunit": "^6",
- "friendsofphp/php-cs-fixer": "^2.8",
- "php-coveralls/php-coveralls": "^1.1.0"
+ "phpunit/phpunit": "^9|^10",
+ "friendsofphp/php-cs-fixer": "^3.14",
+ "php-coveralls/php-coveralls": "^2.5.0"
},
"autoload": {
- "psr-0": {"JShrink": "src/"}
+ "psr-0": {
+ "JShrink": "src/"
+ }
}
}
diff --git a/php-tedivm-jshrink.spec b/php-tedivm-jshrink.spec
index ba8c5e8..f65be8e 100644
--- a/php-tedivm-jshrink.spec
+++ b/php-tedivm-jshrink.spec
@@ -1,14 +1,14 @@
# remirepo/fedora spec file for php-tedivm-jshrink
#
-# Copyright (c) 2015-2021 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%bcond_without tests
-%global gh_commit 0513ba1407b1f235518a939455855e6952a48bbc
+%global gh_commit 8dd2fd54293e94fa1536c3c66700c707d814e043
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner tedious
#global gh_date 20150820
@@ -18,33 +18,33 @@
%global psr0 JShrink
Name: php-%{c_vendor}-%{c_project}
-Version: 1.4.0
+Version: 1.6.1
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Javascript Minifier built in PHP
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{?gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
%if %{with tests}
-BuildRequires: php(language) >= 5.6.0
+BuildRequires: php(language) >= 8.0
BuildRequires: php-date
BuildRequires: php-pcre
BuildRequires: php-spl
# For tests, from composer.json "require-dev": {
-# "phpunit/phpunit": "^6",
-# "friendsofphp/php-cs-fixer": "^2.8",
-# "php-coveralls/php-coveralls": "^1.1.0"
-BuildRequires: phpunit7
+# "phpunit/phpunit": "^9|^10",
+# "friendsofphp/php-cs-fixer": "^3.14",
+# "php-coveralls/php-coveralls": "^2.5.0"
+BuildRequires: phpunit9
%endif
# For autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": "^5.6|^7.0|^8.0"
-Requires: php(language) >= 5.6.0
+# "php": "^8.0"
+Requires: php(language) >= 8.0
# From phpcompatinfo report for 1.1.0
Requires: php-date
Requires: php-pcre
@@ -90,11 +90,10 @@ EOF
: Run upstream test suite
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php80 php81 php82; do
if which $cmd; then
- $cmd %{_bindir}/phpunit7 \
- --no-coverage \
- --verbose || ret=1
+ $cmd %{_bindir}/phpunit9 \
+ --no-coverage || ret=1
fi
done
exit $ret
@@ -113,6 +112,9 @@ exit $ret
%changelog
+* Mon Mar 6 2023 Remi Collet <remi@remirepo.net> - 1.6.1-1
+- update to 1.6.1
+
* Thu Apr 1 2021 Remi Collet <remi@remirepo.net> - 1.4.0-1
- update to 1.4.0
- switch to phpunit7