summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--5.patch36
-rw-r--r--composer.json2
-rw-r--r--php-tecnickcom-tc-lib-unicode.spec23
3 files changed, 13 insertions, 48 deletions
diff --git a/5.patch b/5.patch
deleted file mode 100644
index 9ebaacf..0000000
--- a/5.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From e6cbc5cd2ac0189cbddfe0bf585655ef9dbab2ab Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 13 Sep 2019 11:50:37 +0200
-Subject: [PATCH] Fix: Trying to access array offset on value of type bool
-
----
- src/Bidi.php | 2 +-
- test/BidiTest.php | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/Bidi.php b/src/Bidi.php
-index 3da33c7..cb49a41 100644
---- a/src/Bidi.php
-+++ b/src/Bidi.php
-@@ -176,7 +176,7 @@ protected function setInput($str = null, $chrarr = null, $ordarr = null, $forcer
- $this->str = $str;
- $this->chrarr = $chrarr;
- $this->ordarr = $ordarr;
-- $this->forcertl = (($forcertl === false) ? false : strtoupper($forcertl[0]));
-+ $this->forcertl = (is_string($forcertl) ? strtoupper($forcertl[0]) : false);
- }
-
- /**
-diff --git a/test/BidiTest.php b/test/BidiTest.php
-index 6fed41f..5b9cb0c 100644
---- a/test/BidiTest.php
-+++ b/test/BidiTest.php
-@@ -86,7 +86,7 @@ public function bidiStrDataProvider()
- array(
- "\n\nABC\nEFG\n\nHIJ\n\n",
- "\n\nABC\nEFG\n\nHIJ\n\n",
-- true
-+ 'L'
- ),
- array(
- json_decode('"\u202EABC\u202C"'),
diff --git a/composer.json b/composer.json
index 3e700bc..edcc89c 100644
--- a/composer.json
+++ b/composer.json
@@ -22,7 +22,7 @@
"php": ">=5.4",
"ext-mbstring": "*",
"ext-pcre": "*",
- "tecnickcom/tc-lib-unicode-data": "^1.6.8"
+ "tecnickcom/tc-lib-unicode-data": "^1.6.9"
},
"require-dev": {
"apigen/apigen": "^4.1.2",
diff --git a/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode.spec
index cab5bcd..5fafa0d 100644
--- a/php-tecnickcom-tc-lib-unicode.spec
+++ b/php-tecnickcom-tc-lib-unicode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit ec31b43b1d18a9e61b0f91275dfb1911ad1870e2
+%global gh_commit 382c02f6426e64508a1b46a02897d401286f7859
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,16 +15,14 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.3.8
-Release: 2%{?dist}
+Version: 1.3.9
+Release: 1%{?dist}
Summary: PHP library containing Unicode methods
License: LGPLv3+
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
-Patch0: https://patch-diff.githubusercontent.com/raw/tecnickcom/tc-lib-unicode/pull/5.patch
-
BuildArch: noarch
%if %{with_tests}
# For tests
@@ -36,10 +34,10 @@ BuildArch: noarch
BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.9 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
%else
BuildRequires: php-composer(%{c_vendor}/tc-lib-unicode-data) < 2
-BuildRequires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3
+BuildRequires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.9
%endif
BuildRequires: php-mbstring
BuildRequires: php-pcre
@@ -49,15 +47,15 @@ BuildRequires: php-pcre
# "php": ">=5.4"
# "ext-mbstring": "*",
# "ext-pcre": "*",
-# "tecnickcom/tc-lib-unicode-data": "^1.6.0"
+# "tecnickcom/tc-lib-unicode-data": "^1.6.9"
Requires: php(language) >= 5.4
Requires: php-mbstring
Requires: php-pcre
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
+Requires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.9 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
%else
Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) < 2
-Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.3
+Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.9
%endif
# From phpcompatinfo report for version 1.2.1
# None
@@ -77,7 +75,6 @@ The initial source code has been derived from TCPDF (http://www.tcpdf.org/).
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
: Sanity check
grep -q '^%{version}$' VERSION
@@ -125,6 +122,10 @@ exit $ret
%changelog
+* Fri Sep 20 2019 Remi Collet <remi@remirepo.net> - 1.3.9-1
+- update to 1.3.9
+- drop patch merged upstream
+
* Fri Sep 13 2019 Remi Collet <remi@remirepo.net> - 1.3.8-2
- add patch for 7.4 from
https://github.com/tecnickcom/tc-lib-unicode/pull/5