summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-unicode.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-10-23 14:09:46 +0200
committerRemi Collet <remi@php.net>2023-10-23 14:09:46 +0200
commit0ac2e744f39aeb5efccc871694b159370fb47cde (patch)
tree5d743278391326c464ec03bde20831cdd842b946 /php-tecnickcom-tc-lib-unicode.spec
parentf217c0c19c36e4c0da0489a52c53bcf12810b484 (diff)
update to 1.4.33 (no change)
Diffstat (limited to 'php-tecnickcom-tc-lib-unicode.spec')
-rw-r--r--php-tecnickcom-tc-lib-unicode.spec24
1 files changed, 18 insertions, 6 deletions
diff --git a/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode.spec
index 65e766e..3e0700c 100644
--- a/php-tecnickcom-tc-lib-unicode.spec
+++ b/php-tecnickcom-tc-lib-unicode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit a62043493c1b44ead431df581e1a3dbc89f0e903
+%global gh_commit 889ab8bb2d48dfb7fa510498c16cbd0df3472348
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.4.31
+Version: 1.4.33
Release: 1%{?dist}
Summary: PHP library containing Unicode methods
@@ -26,8 +26,15 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
+# remirepo:1
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
+%global phpunit %{_bindir}/phpunit10
+BuildRequires: phpunit10
+# remirepo:4
+%else
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.5.27
+%endif
BuildRequires: php(language) >= 5.4
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.7 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
@@ -102,11 +109,12 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php80 %{phpunit}" php81 php82 php83; do
+for cmdarg in php "php80 %{_bindir}/phpunit9" php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit10} --migrate-configuration || :
- $1 ${2:-%{_bindir}/phpunit10} --no-coverage || ret=1
+ cp phpunit.xml.dist phpunit.xml
+ $1 ${2:-%{phpunit}} --migrate-configuration || :
+ $1 ${2:-%{phpunit}} --no-coverage || ret=1
fi
done
exit $ret
@@ -116,14 +124,18 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
-%doc README.md
+%doc *.md
%{php_project}/*
%changelog
+* Mon Oct 23 2023 Remi Collet <remi@remirepo.net> - 1.4.33-1
+- update to 1.4.33 (no change)
+
* Thu Oct 12 2023 Remi Collet <remi@remirepo.net> - 1.4.31-1
- update to 1.4.31