summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-22 14:10:42 +0100
committerRemi Collet <remi@php.net>2023-11-22 14:10:42 +0100
commit5ecaa082ff26b17df2ed97390eab75d30e5251e0 (patch)
tree26b5a1c7f6cbca0f836d85f5002209615d48128e
parent0ac2e744f39aeb5efccc871694b159370fb47cde (diff)
update to 2.0.7
raise dependency on PHP 8 raise dependency on tc-lib-unicode-data 2.0
-rw-r--r--composer.json8
-rw-r--r--php-tecnickcom-tc-lib-unicode.spec33
2 files changed, 23 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index 9f66ad9..ee2bcff 100644
--- a/composer.json
+++ b/composer.json
@@ -19,16 +19,16 @@
}
],
"require": {
- "php": ">=5.4",
+ "php": ">=8.0",
"ext-mbstring": "*",
"ext-pcre": "*",
- "tecnickcom/tc-lib-unicode-data": "^1.7"
+ "tecnickcom/tc-lib-unicode-data": "^2.0"
},
"require-dev": {
"pdepend/pdepend": "2.13.0",
"phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.7 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
- "squizlabs/php_codesniffer": "3.7.2 || 2.9.2"
+ "phpunit/phpunit": "10.1.2 || 9.6.13",
+ "squizlabs/php_codesniffer": "3.7.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode.spec
index 3e0700c..e765dd8 100644
--- a/php-tecnickcom-tc-lib-unicode.spec
+++ b/php-tecnickcom-tc-lib-unicode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 889ab8bb2d48dfb7fa510498c16cbd0df3472348
+%global gh_commit 6302bdc710495ccfb5dba94b7848a348ae9c52e9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.4.33
+Version: 2.0.7
Release: 1%{?dist}
Summary: PHP library containing Unicode methods
@@ -29,18 +29,18 @@ BuildArch: noarch
# remirepo:1
%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10
+BuildRequires: phpunit10 >= 10.1.2
# remirepo:4
%else
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.27
+BuildRequires: phpunit9 >= 9.6.13
%endif
-BuildRequires: php(language) >= 5.4
+BuildRequires: php(language) >= 8.0
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.7 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 2.0 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 3)
%else
-BuildRequires: php-%{c_vendor}-tc-lib-unicode-data < 2
-BuildRequires: php-%{c_vendor}-tc-lib-unicode-data >= 1.7
+BuildRequires: php-%{c_vendor}-tc-lib-unicode-data < 3
+BuildRequires: php-%{c_vendor}-tc-lib-unicode-data >= 2.0
%endif
BuildRequires: php-mbstring
BuildRequires: php-pcre
@@ -48,18 +48,18 @@ BuildRequires: php-pcre
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=5.4"
+# "php": ">=8.0"
# "ext-mbstring": "*",
# "ext-pcre": "*",
-# "tecnickcom/tc-lib-unicode-data": "^1.7"
-Requires: php(language) >= 5.4
+# "tecnickcom/tc-lib-unicode-data": "^2.0"
+Requires: php(language) >= 8.0
Requires: php-mbstring
Requires: php-pcre
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.7 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
+Requires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 2.0 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 3)
%else
-Requires: php-%{c_vendor}-tc-lib-unicode-data < 2
-Requires: php-%{c_vendor}-tc-lib-unicode-data >= 1.7
+Requires: php-%{c_vendor}-tc-lib-unicode-data < 3
+Requires: php-%{c_vendor}-tc-lib-unicode-data >= 2.0
%endif
# From phpcompatinfo report for version 1.2.1
# None
@@ -133,6 +133,11 @@ exit $ret
%changelog
+* Wed Nov 22 2023 Remi Collet <remi@remirepo.net> - 2.0.7-1
+- update to 2.0.7
+- raise dependency on PHP 8
+- raise dependency on tc-lib-unicode-data 2.0
+
* Mon Oct 23 2023 Remi Collet <remi@remirepo.net> - 1.4.33-1
- update to 1.4.33 (no change)