summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-21 11:36:50 +0100
committerRemi Collet <remi@remirepo.net>2020-12-21 11:36:50 +0100
commit2f66798ac2bd3a7286daa30ca7b6ee7fca7a2554 (patch)
treecda8ffbe48fdb3dc7b1518c6a5275622066ebd3e
parent103af8673ff8ce907165f8bc11e3d67eae54d97e (diff)
update to 1.4.1
switch to classmap autoloader
-rw-r--r--composer.json19
-rw-r--r--php-tecnickcom-tc-lib-unicode.spec50
2 files changed, 40 insertions, 29 deletions
diff --git a/composer.json b/composer.json
index 2bec0a0..861dab0 100644
--- a/composer.json
+++ b/composer.json
@@ -22,21 +22,22 @@
"php": ">=5.4",
"ext-mbstring": "*",
"ext-pcre": "*",
- "tecnickcom/tc-lib-unicode-data": "^1.6.11"
+ "tecnickcom/tc-lib-unicode-data": "^1.7"
},
"require-dev": {
- "apigen/apigen": "^4.1.2",
- "bartlett/php-compatinfo": "^5.0.10 || ^5.0.12",
- "pdepend/pdepend": "^2.5.2",
- "phploc/phploc": "^2.1 || ^3.0 || ^4.0",
- "phpmd/phpmd": "^2.6.0",
- "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.1",
- "sebastian/phpcpd": "^2.0 || ^3.0 || ^4.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.2.0"
+ "pdepend/pdepend": "2.8.0",
+ "phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
+ "phpmd/phpmd": "2.9.1",
+ "phpunit/phpunit": "9.5.0 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
+ "squizlabs/php_codesniffer": "3.5.8 || 2.9.2"
},
"autoload": {
"psr-4": {
"Com\\Tecnick\\Unicode\\": "src"
}
+ },
+ "autoload-dev": {
+ "psr-4": { "Test\\": "test" }
}
}
diff --git a/php-tecnickcom-tc-lib-unicode.spec b/php-tecnickcom-tc-lib-unicode.spec
index baa6ecb..105b2e3 100644
--- a/php-tecnickcom-tc-lib-unicode.spec
+++ b/php-tecnickcom-tc-lib-unicode.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit c9eb7f74ec02941ba42822e5f752ee401e108109
+%global gh_commit 431064feee773b571682f1312648799e3d45315d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.3.11
+Version: 1.4.1
Release: 1%{?dist}
Summary: PHP library containing Unicode methods
@@ -26,39 +26,42 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit7
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.5.0
%else
-%global phpunit %{_bindir}/phpunit
+%global phpunit %{_bindir}/phpunit8
+BuildRequires: phpunit8 >= 8.5.13
%endif
-BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.9 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.7 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
%else
-BuildRequires: php-composer(%{c_vendor}/tc-lib-unicode-data) < 2
-BuildRequires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.9
+BuildRequires: php-%{c_vendor}-tc-lib-unicode-data < 2
+BuildRequires: php-%{c_vendor}-tc-lib-unicode-data >= 1.7
%endif
BuildRequires: php-mbstring
BuildRequires: php-pcre
%endif
+BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": ">=5.4"
# "ext-mbstring": "*",
# "ext-pcre": "*",
-# "tecnickcom/tc-lib-unicode-data": "^1.6.9"
+# "tecnickcom/tc-lib-unicode-data": "^1.7"
Requires: php(language) >= 5.4
Requires: php-mbstring
Requires: php-pcre
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.9 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
+Requires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.7 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 2)
%else
-Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) < 2
-Requires: php-composer(%{c_vendor}/tc-lib-unicode-data) >= 1.6.9
+Requires: php-%{c_vendor}-tc-lib-unicode-data < 2
+Requires: php-%{c_vendor}-tc-lib-unicode-data >= 1.7
%endif
# From phpcompatinfo report for version 1.2.1
# None
+BuildRequires: php-fedora-autoloader-devel
# Composer
Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
@@ -81,30 +84,33 @@ grep -q '^%{version}$' VERSION
%build
-# Empty build section, most likely nothing required.
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{_datadir}/php/Com/Tecnick/Unicode/Data/autoload.php',
+]);
+EOF
%install
mkdir -p $(dirname %{buildroot}%{php_project})
cp -pr src %{buildroot}%{php_project}
-cp -p resources/autoload.php \
- %{buildroot}%{php_project}/autoload.php
%check
%if %{with_tests}
mkdir vendor
-cat <<EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require '%{buildroot}%{php_project}/autoload.php';
-require '%{php_project}/Data/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('Test\\', dirname(__DIR__) . '/test');
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -122,6 +128,10 @@ exit $ret
%changelog
+* Mon Dec 21 2020 Remi Collet <remi@remirepo.net> - 1.4.1-1
+- update to 1.4.1
+- switch to classmap autoloader
+
* Fri Jan 3 2020 Remi Collet <remi@remirepo.net> - 1.3.11-1
- update to 1.3.11 (no change)