summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-22 13:46:40 +0100
committerRemi Collet <remi@php.net>2023-11-22 13:46:40 +0100
commita7119cc0ee720bd71db26c7e8bf7c5dbc8892c5f (patch)
treef2ac98121a938d4d6fff226a6cd26fc6d56dc724
parent8ac0968808aab6b25b1f4bcea26cd1ab44dee576 (diff)
update to 2.0.7
raise dependency on PHP 8
-rw-r--r--composer.json6
-rw-r--r--php-tecnickcom-tc-lib-unicode-data.spec18
2 files changed, 14 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 214a2ee..1cc5d0d 100644
--- a/composer.json
+++ b/composer.json
@@ -19,13 +19,13 @@
}
],
"require": {
- "php": ">=5.4"
+ "php": ">=8.0"
},
"require-dev": {
"pdepend/pdepend": "2.13.0",
"phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.7 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
- "squizlabs/php_codesniffer": "3.7.2 || 2.9.2"
+ "phpunit/phpunit": "10.1.2 || 9.6.13",
+ "squizlabs/php_codesniffer": "3.7.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-unicode-data.spec b/php-tecnickcom-tc-lib-unicode-data.spec
index 864a9fa..add1a94 100644
--- a/php-tecnickcom-tc-lib-unicode-data.spec
+++ b/php-tecnickcom-tc-lib-unicode-data.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit aaef614a8065787ae962e9146ea1eb0dfe74240f
+%global gh_commit fdf7f66054f704ac8ce7bf6826476f8671e211a7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.7.33
+Version: 2.0.7
Release: 1%{?dist}
Summary: PHP library containing UTF-8 font definitions
@@ -29,19 +29,19 @@ BuildArch: noarch
# remirepo:1
%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10
+BuildRequires: phpunit10 >= 10.1.2
# remirepo:4
%else
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.27
+BuildRequires: phpunit9 >= 9.6.13
%endif
-BuildRequires: php(language) >= 5.4
+BuildRequires: php(language) >= 8.0
%endif
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=5.4"
-Requires: php(language) >= 5.4
+# "php": ">=8.0"
+Requires: php(language) >= 8.0
# From phpcompatinfo report for version 1.1.1
# Only Core
Requires: php-composer(fedora/autoloader)
@@ -114,6 +114,10 @@ exit $ret
%changelog
+* Wed Nov 22 2023 Remi Collet <remi@remirepo.net> - 2.0.7-1
+- update to 2.0.7
+- raise dependency on PHP 8
+
* Mon Oct 23 2023 Remi Collet <remi@remirepo.net> - 1.7.33-1
- update to 1.7.33 (no change)