summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-06-25 08:51:25 +0200
committerRemi Collet <remi@remirepo.net>2018-06-25 08:51:25 +0200
commit08688d2d67a71320d5ba5e45c5324754ccd1f5cc (patch)
treec7319f8ac0c208f52000ba8d9fe5e779ae8bb308
parentefb0c4d8a5f1c0f9ae91fc258795d50e2446336b (diff)
v1.6.8 (no change)
-rw-r--r--composer.json12
-rw-r--r--php-tecnickcom-tc-lib-unicode-data.spec11
2 files changed, 13 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 64b3aca..1122f28 100644
--- a/composer.json
+++ b/composer.json
@@ -23,13 +23,13 @@
},
"require-dev": {
"apigen/apigen": "^4.1.2",
- "bartlett/php-compatinfo": "^5.0.4",
- "pdepend/pdepend": "^2.5.0",
- "phploc/phploc": "^2.1.5 || ^3.0.1",
+ "bartlett/php-compatinfo": "^5.0.10 || ^5.0.12",
+ "pdepend/pdepend": "^2.5.2",
+ "phploc/phploc": "^2.1 || ^3.0 || ^4.0",
"phpmd/phpmd": "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd": "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
+ "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.1",
+ "sebastian/phpcpd": "^2.0 || ^3.0 || ^4.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.2.0"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-unicode-data.spec b/php-tecnickcom-tc-lib-unicode-data.spec
index 9bbf9aa..2750698 100644
--- a/php-tecnickcom-tc-lib-unicode-data.spec
+++ b/php-tecnickcom-tc-lib-unicode-data.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 4e4fb6386190d20672a2cd303af07b385fe02e3c
+%global gh_commit 84ea2f4a146c914d76c9139b7c88c9f9bbe59fc2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.6.7
+Version: 1.6.8
Release: 1%{?dist}
Summary: PHP library containing UTF-8 font definitions
@@ -61,7 +61,7 @@ The initial source code has been extracted from TCPDF (http://www.tcpdf.org).
# See https://github.com/tecnickcom/tc-lib-unicode-data/issues/3
: Sanity check
-#grep -q '^%{version}$' VERSION
+grep -q '^%{version}$' VERSION
%build
@@ -84,7 +84,7 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72 php73; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
@@ -108,6 +108,9 @@ exit $ret
%changelog
+* Mon Jun 25 2018 Remi Collet <remi@remirepo.net> - 1.6.8-1
+- update to 1.6.8 (no change)
+
* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 1.6.7-1
- update to 1.6.7 (no change)
- switch to phpunit7