summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-30 08:13:50 +0100
committerRemi Collet <remi@php.net>2023-11-30 08:13:50 +0100
commit458a93e93dac844bb224f52f85590800310d1b01 (patch)
tree9c9485e680f75a4b539bd69f33bec7f37109c41f
parent46e945abfb35604404e8eece4fa9b4c8653d6c99 (diff)
update to 8.0.55
raise dependency on tc-lib-pdf-encrypt 2.1
-rw-r--r--composer.json2
-rw-r--r--php-tecnickcom-tc-lib-pdf.spec18
2 files changed, 12 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index cafcade..1678987 100644
--- a/composer.json
+++ b/composer.json
@@ -27,7 +27,7 @@
"tecnickcom/tc-lib-pdf-image": "^2.0",
"tecnickcom/tc-lib-pdf-font": "^2.0",
"tecnickcom/tc-lib-file": "^2.0",
- "tecnickcom/tc-lib-pdf-encrypt": "^2.0",
+ "tecnickcom/tc-lib-pdf-encrypt": "^2.1",
"tecnickcom/tc-lib-unicode-data": "^2.0",
"tecnickcom/tc-lib-unicode": "^2.0",
"tecnickcom/tc-lib-pdf-page": "^4.0",
diff --git a/php-tecnickcom-tc-lib-pdf.spec b/php-tecnickcom-tc-lib-pdf.spec
index b0ed578..141f8da 100644
--- a/php-tecnickcom-tc-lib-pdf.spec
+++ b/php-tecnickcom-tc-lib-pdf.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit ff6a98586d852dc82c9caa4b57a2f1b66c111b8c
+%global gh_commit 95a1fa0e0d7372b26e86be8d41f371cded9d2eb9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%bcond_without tests
Name: php-%{gh_owner}-%{gh_project}
-Version: 8.0.53
+Version: 8.0.55
Release: 1%{?dist}
Summary: PHP PDF Library
@@ -36,7 +36,7 @@ BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.0 with php
BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-image) >= 2.0 with php-composer(%{c_vendor}/tc-lib-pdf-image) < 3)
BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-font) >= 2.0 with php-composer(%{c_vendor}/tc-lib-pdf-font) < 3)
BuildRequires: (php-composer(%{c_vendor}/tc-lib-file) >= 2.0 with php-composer(%{c_vendor}/tc-lib-file) < 3)
-BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.0 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 3)
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.1 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 3)
BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 2.0 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 3)
BuildRequires: (php-composer(%{c_vendor}/tc-lib-unicode) >= 2.0 with php-composer(%{c_vendor}/tc-lib-unicode) < 3)
BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-page) >= 4.0 with php-composer(%{c_vendor}/tc-lib-pdf-page) < 5)
@@ -54,7 +54,7 @@ BuildRequires: php-%{c_vendor}-tc-lib-pdf-font >= 2.0
BuildRequires: php-%{c_vendor}-tc-lib-file < 3
BuildRequires: php-%{c_vendor}-tc-lib-file >= 2.0
BuildRequires: php-%{c_vendor}-tc-lib-pdf-encrypt < 3
-BuildRequires: php-%{c_vendor}-tc-lib-pdf-encrypt >= 2.0
+BuildRequires: php-%{c_vendor}-tc-lib-pdf-encrypt >= 2.1
BuildRequires: php-%{c_vendor}-tc-lib-unicode-data < 3
BuildRequires: php-%{c_vendor}-tc-lib-unicode-data >= 2.0
BuildRequires: php-%{c_vendor}-tc-lib-unicode < 3
@@ -81,7 +81,7 @@ BuildRequires: php-fedora-autoloader-devel
# "tecnickcom/tc-lib-pdf-image": "^2.0",
# "tecnickcom/tc-lib-pdf-font": "^2.0",
# "tecnickcom/tc-lib-file": "^2.0",
-# "tecnickcom/tc-lib-pdf-encrypt": "^2.0",
+# "tecnickcom/tc-lib-pdf-encrypt": "^2.1",
# "tecnickcom/tc-lib-unicode-data": "^2.0",
# "tecnickcom/tc-lib-unicode": "^2.0",
# "tecnickcom/tc-lib-pdf-page": "^4.0",
@@ -96,7 +96,7 @@ Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.0 with php
Requires: (php-composer(%{c_vendor}/tc-lib-pdf-image) >= 2.0 with php-composer(%{c_vendor}/tc-lib-pdf-image) < 3)
Requires: (php-composer(%{c_vendor}/tc-lib-pdf-font) >= 2.0 with php-composer(%{c_vendor}/tc-lib-pdf-font) < 3)
Requires: (php-composer(%{c_vendor}/tc-lib-file) >= 2.0 with php-composer(%{c_vendor}/tc-lib-file) < 3)
-Requires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.0 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 3)
+Requires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.1 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 3)
Requires: (php-composer(%{c_vendor}/tc-lib-unicode-data) >= 2.0 with php-composer(%{c_vendor}/tc-lib-unicode-data) < 3)
Requires: (php-composer(%{c_vendor}/tc-lib-unicode) >= 2.0 with php-composer(%{c_vendor}/tc-lib-unicode) < 3)
Requires: (php-composer(%{c_vendor}/tc-lib-pdf-page) >= 4.0 with php-composer(%{c_vendor}/tc-lib-pdf-page) < 5)
@@ -114,7 +114,7 @@ Requires: php-%{c_vendor}-tc-lib-pdf-font >= 2.0
Requires: php-%{c_vendor}-tc-lib-file < 3
Requires: php-%{c_vendor}-tc-lib-file >= 2.0
Requires: php-%{c_vendor}-tc-lib-pdf-encrypt < 3
-Requires: php-%{c_vendor}-tc-lib-pdf-encrypt >= 2.0
+Requires: php-%{c_vendor}-tc-lib-pdf-encrypt >= 2.1
Requires: php-%{c_vendor}-tc-lib-unicode-data < 3
Requires: php-%{c_vendor}-tc-lib-unicode-data >= 2.0
Requires: php-%{c_vendor}-tc-lib-unicode < 3
@@ -248,5 +248,9 @@ exit $ret
%changelog
+* Thu Nov 30 2023 Remi Collet <remi@remirepo.net> - 8.0.55-1
+- update to 8.0.55
+- raise dependency on tc-lib-pdf-encrypt 2.1
+
* Wed Nov 29 2023 Remi Collet <remi@remirepo.net> - 8.0.53-1
- initial package, version 8.0.53