summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-14 07:36:25 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-14 07:36:25 +0200
commitb2c193530e8ff2ea20d4b1cb708b2ca14301afba (patch)
treed923117045153f4c0dcde37b3a5a93f6dd5bc871
parent2c0e4089b994f652122bf5af000231d2f530319b (diff)
php-tecnickcom-tc-lib-pdf-parser: 2.3.0 (no change)
-rw-r--r--composer.json40
-rw-r--r--php-tecnickcom-tc-lib-pdf-parser.spec11
2 files changed, 47 insertions, 4 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..11b7822
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,40 @@
+{
+ "name": "tecnickcom/tc-lib-pdf-parser",
+ "description": "PHP library to parse PDF documents",
+ "type": "library",
+ "homepage": "http://www.tecnick.com",
+ "license": "LGPL-3.0",
+ "keywords": ["tc-lib-pdf-parser", "PDF", "parser", "document"],
+ "authors": [
+ {
+ "name": "Nicola Asuni",
+ "email": "info@tecnick.com",
+ "role": "lead"
+ }
+ ],
+ "require": {
+ "php": ">=5.4",
+ "tecnickcom/tc-lib-pdf-filter": "^1.3.0"
+ },
+ "require-dev": {
+ "apigen/apigen" : "^4.1.2",
+ "bartlett/php-compatinfo" : "^5.0.0",
+ "pdepend/pdepend" : "^2.2.2",
+ "phploc/phploc" : "^2.1.5|^3.0.0",
+ "phpmd/phpmd" : "^2.3.2",
+ "phpunit/phpunit": "4.8.19|^5.0.0",
+ "sebastian/phpcpd" : "^2.0.2",
+ "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ },
+ "autoload": {
+ "psr-4":{
+ "Com\\Tecnick\\Pdf\\Parser\\": "src"
+ }
+ },
+ "repositories": [
+ {
+ "type": "vcs",
+ "url": "git@github.com:tecnickcom/tc-lib-pdf-filter.git"
+ }
+ ]
+}
diff --git a/php-tecnickcom-tc-lib-pdf-parser.spec b/php-tecnickcom-tc-lib-pdf-parser.spec
index 0d0b6f0..267de48 100644
--- a/php-tecnickcom-tc-lib-pdf-parser.spec
+++ b/php-tecnickcom-tc-lib-pdf-parser.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 5c0a8fdccc17abb3c25ab3dadf752fab01b9ff4b
+%global gh_commit 4d1ecdecd96dc6e770351cfca1aeaed72893bbfc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.2.3
+Version: 2.3.0
Release: 1%{?dist}
Summary: PHP library to parse PDF documents
@@ -36,9 +36,9 @@ BuildRequires: php-pcre
# From composer.json, "require": {
# "php": ">=5.4"
-# "tecnick.com/tc-lib-pdf-filter": "^1.2.0"
+# "tecnick.com/tc-lib-pdf-filter": "^1.3.0"
Requires: php(language) >= 5.4
-Requires: php-composer(%{c_vendor}/tc-lib-pdf-filter) >= 1.2.0
+Requires: php-composer(%{c_vendor}/tc-lib-pdf-filter) >= 1.3.0
Requires: php-composer(%{c_vendor}/tc-lib-pdf-filter) < 2
# From phpcompatinfo report for version 2.1.0
Requires: php-pcre
@@ -114,6 +114,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 2.3.0-1
+- update to 2.3.0 (no change)
+
* Fri Mar 4 2016 Remi Collet <remi@fedoraproject.org> - 2.2.3-1
- update to 2.2.3 (no change)