summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-10-23 14:08:05 +0200
committerRemi Collet <remi@php.net>2023-10-23 14:08:05 +0200
commita117bed6cf3444d8f8aa6c740e25eb233a7c670f (patch)
treed825eaa65e5cff615de2cff074c3c4eaef04857e
parent75d87c39932ea2aa610c67722a80780a1467aaf7 (diff)
update to 2.4.33 (no change)
-rw-r--r--php-tecnickcom-tc-lib-pdf-parser.spec24
1 files changed, 18 insertions, 6 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-parser.spec b/php-tecnickcom-tc-lib-pdf-parser.spec
index 8249e62..d1b58cd 100644
--- a/php-tecnickcom-tc-lib-pdf-parser.spec
+++ b/php-tecnickcom-tc-lib-pdf-parser.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 7633b51c20b3c598d5cad4b05e2bf9e35068bc7e
+%global gh_commit 668b3c41d28d7791caed257e457279f89df4151a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.31
+Version: 2.4.33
Release: 1%{?dist}
Summary: PHP library to parse PDF documents
@@ -26,8 +26,15 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
+# remirepo:1
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
+%global phpunit %{_bindir}/phpunit10
+BuildRequires: phpunit10
+# remirepo:4
+%else
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.5.27
+%endif
BuildRequires: php(language) >= 5.4
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-filter) >= 1.4 with php-composer(%{c_vendor}/tc-lib-pdf-filter) < 2)
@@ -105,11 +112,12 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php80 %{phpunit}" php81 php82 php83; do
+for cmdarg in php "php80 %{_bindir}/phpunit9" php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit10} --migrate-configuration || :
- $1 ${2:-%{_bindir}/phpunit10} --no-coverage || ret=1
+ cp phpunit.xml.dist phpunit.xml
+ $1 ${2:-%{phpunit}} --migrate-configuration || :
+ $1 ${2:-%{phpunit}} --no-coverage || ret=1
fi
done
exit $ret
@@ -119,14 +127,18 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
-%doc README.md example
+%doc *.md example
%{php_project}
%changelog
+* Mon Oct 23 2023 Remi Collet <remi@remirepo.net> - 2.4.33-1
+- update to 2.4.33 (no change)
+
* Thu Oct 12 2023 Remi Collet <remi@remirepo.net> - 2.4.31-1
- update to 2.4.31