summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-03 09:29:01 +0100
committerRemi Collet <remi@php.net>2022-01-03 09:29:01 +0100
commit34fec1afb75c1d709b72b6b4240c724310fbbf04 (patch)
tree69cb4e79238c2ab4512eeea885246d414beb875d
parent74c14bb53797d23d0421c20a62d1698fdb39baa7 (diff)
update to 2.4.7 (no change)
-rw-r--r--composer.json8
-rw-r--r--php-tecnickcom-tc-lib-pdf-parser.spec11
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 1401842..acecb5d 100644
--- a/composer.json
+++ b/composer.json
@@ -23,12 +23,12 @@
"tecnickcom/tc-lib-pdf-filter": "^1.4"
},
"require-dev": {
- "pdepend/pdepend": "2.8.0",
+ "pdepend/pdepend": "2.10.2",
"phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
- "phpmd/phpmd": "2.9.1",
- "phpunit/phpunit": "9.5.0 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "phpmd/phpmd": "2.11.1",
+ "phpunit/phpunit": "9.5.11 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
"sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
- "squizlabs/php_codesniffer": "3.5.8 || 2.9.2"
+ "squizlabs/php_codesniffer": "3.6.2 || 2.9.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-parser.spec b/php-tecnickcom-tc-lib-pdf-parser.spec
index c4ce3af..8d2a80f 100644
--- a/php-tecnickcom-tc-lib-pdf-parser.spec
+++ b/php-tecnickcom-tc-lib-pdf-parser.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-parser
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 6f220275e8924188883b4746cce56d6a19e55d10
+%global gh_commit f1ec20911cacfa708526a20b92725f92aaad0cf4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.4
+Version: 2.4.7
Release: 1%{?dist}
Summary: PHP library to parse PDF documents
@@ -110,7 +110,7 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
@@ -131,6 +131,9 @@ exit $ret
%changelog
+* Mon Jan 3 2022 Remi Collet <remi@remirepo.net> - 2.4.7-1
+- update to 2.4.7 (no change)
+
* Mon Feb 8 2021 Remi Collet <remi@remirepo.net> - 2.4.4-1
- update to 2.4.4 (no change)