summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json8
-rw-r--r--php-tecnickcom-tc-lib-pdf-page.spec17
2 files changed, 14 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 49e35e8..5130db2 100644
--- a/composer.json
+++ b/composer.json
@@ -25,12 +25,12 @@
"tecnickcom/tc-lib-pdf-encrypt": "^1.6.0"
},
"require-dev": {
- "pdepend/pdepend": "2.10.2",
+ "pdepend/pdepend": "2.12.1",
"phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
- "phpmd/phpmd": "2.11.1",
- "phpunit/phpunit": "9.5.11 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "phpmd/phpmd": "2.13.0",
+ "phpunit/phpunit": "9.5.27 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
"sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
- "squizlabs/php_codesniffer": "3.6.2 || 2.9.2"
+ "squizlabs/php_codesniffer": "3.7.1 || 2.9.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-page.spec b/php-tecnickcom-tc-lib-pdf-page.spec
index cec1385..24ee267 100644
--- a/php-tecnickcom-tc-lib-pdf-page.spec
+++ b/php-tecnickcom-tc-lib-pdf-page.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit f24f78baf2048450684ce4c120439e6e3f30fb54
+%global gh_commit 266441677929add92ca7683def267c570f548d10
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,11 +15,11 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.8
+Version: 2.5.12
Release: 1%{?dist}
Summary: PHP library containing PDF page formats and definitions
-License: LGPLv3+
+License: LGPL-3.0-or-later
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
@@ -27,7 +27,7 @@ BuildArch: noarch
%if %{with_tests}
# For tests
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.0
+BuildRequires: phpunit9 >= 9.5.27
BuildRequires: php(language) >= 5.4
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.14 with php-composer(%{c_vendor}/tc-lib-color) < 2)
@@ -47,8 +47,8 @@ BuildRequires: php-fedora-autoloader-devel
# "php": ">=5.4"
# "ext-date": "*",
# "ext-zlib": "*",
-# "tecnickcom/tc-lib-color": "^1.12.13"
-# "tecnickcom/tc-lib-pdf-encrypt": "^1.5.8",
+# "tecnickcom/tc-lib-color": "^1.14"
+# "tecnickcom/tc-lib-pdf-encrypt": "^1.6.0",
Requires: php(language) >= 5.4
Requires: php-date
Requires: php-zlib
@@ -109,7 +109,7 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
@@ -130,6 +130,9 @@ exit $ret
%changelog
+* Thu Dec 22 2022 Remi Collet <remi@remirepo.net> - 2.5.12-1
+- update to 2.5.12
+
* Tue Jun 14 2022 Remi Collet <remi@remirepo.net> - 2.5.8-1
- update to 2.5.8 (no change)