summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-05-03 09:08:54 +0200
committerRemi Collet <remi@php.net>2023-05-03 09:08:54 +0200
commitbe4e28f216e6f729108cefbabaf083cf27b0d3d2 (patch)
treeec71c37e426a5164bee863ec06626177b2c5f6e6
parent084fe526d5966618d7676b4ddc425411f1e6e003 (diff)
update to 3.1.2
-rw-r--r--composer.json6
-rw-r--r--php-tecnickcom-tc-lib-pdf-page.spec15
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 5130db2..2f911d3 100644
--- a/composer.json
+++ b/composer.json
@@ -25,12 +25,12 @@
"tecnickcom/tc-lib-pdf-encrypt": "^1.6.0"
},
"require-dev": {
- "pdepend/pdepend": "2.12.1",
+ "pdepend/pdepend": "2.13.0",
"phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
"phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "9.5.27 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "phpunit/phpunit": "10.1.2 || 9.6.7 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
"sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
- "squizlabs/php_codesniffer": "3.7.1 || 2.9.2"
+ "squizlabs/php_codesniffer": "3.7.2 || 2.9.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-page.spec b/php-tecnickcom-tc-lib-pdf-page.spec
index e27a43e..4a2d227 100644
--- a/php-tecnickcom-tc-lib-pdf-page.spec
+++ b/php-tecnickcom-tc-lib-pdf-page.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-page
#
-# Copyright (c) 2015-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 51cf811b566ac60211021a660f71ac7bc40f7032
+%global gh_commit eefa6f21c818735c96a8351da6ece920b5447062
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.1.1
+Version: 3.1.2
Release: 1%{?dist}
Summary: PHP library containing PDF page formats and definitions
@@ -109,10 +109,10 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php80 php81 php82; do
+for cmdarg in "php %{phpunit}" "php80 %{phpunit}" php81 php82; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit10} --no-coverage || ret=1
fi
done
exit $ret
@@ -130,6 +130,9 @@ exit $ret
%changelog
+* Wed May 3 2023 Remi Collet <remi@remirepo.net> - 3.1.2-1
+- update to 3.1.2
+
* Mon Jan 2 2023 Remi Collet <remi@remirepo.net> - 3.1.1-1
- update to 3.1.1