summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-20 11:15:24 +0200
committerRemi Collet <remi@remirepo.net>2019-09-20 11:15:24 +0200
commit9b515583332d37f9531df537c691c0dac5479799 (patch)
treeb7d1361219aadbd4fd10294b99cc2e741a56a9fa
parente5f782c3fa8cfbc95e5924d710083929e17ca5a9 (diff)
v2.4.8 (no change)
-rw-r--r--composer.json4
-rw-r--r--php-tecnickcom-tc-lib-pdf-page.spec32
2 files changed, 19 insertions, 17 deletions
diff --git a/composer.json b/composer.json
index 37225dc..6637003 100644
--- a/composer.json
+++ b/composer.json
@@ -21,8 +21,8 @@
"php": ">=5.4",
"ext-date": "*",
"ext-zlib": "*",
- "tecnickcom/tc-lib-color": "^1.12.12",
- "tecnickcom/tc-lib-pdf-encrypt": "^1.5.7"
+ "tecnickcom/tc-lib-color": "^1.12.13",
+ "tecnickcom/tc-lib-pdf-encrypt": "^1.5.8"
},
"require-dev": {
"apigen/apigen": "^4.1.2",
diff --git a/php-tecnickcom-tc-lib-pdf-page.spec b/php-tecnickcom-tc-lib-pdf-page.spec
index b0347fa..a1b9906 100644
--- a/php-tecnickcom-tc-lib-pdf-page.spec
+++ b/php-tecnickcom-tc-lib-pdf-page.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-page
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit ec043599971d6abe6ba9cd5fbb33fa81e12f8868
+%global gh_commit d032e254f972d026bf1f35953dd95dc941405292
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,11 +15,10 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.7
+Version: 2.4.8
Release: 1%{?dist}
Summary: PHP library containing PDF page formats and definitions
-Group: Development/Libraries
License: LGPLv3+
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
@@ -35,13 +34,13 @@ BuildArch: noarch
BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1 with php-composer(%{c_vendor}/tc-lib-color) < 2)
-BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2)
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.12.13 with php-composer(%{c_vendor}/tc-lib-color) < 2)
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.8 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2)
%else
BuildRequires: php-composer(%{c_vendor}/tc-lib-color) < 2
-BuildRequires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1
+BuildRequires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.13
BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2
-BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2
+BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.8
%endif
BuildRequires: php-date
BuildRequires: php-zlib
@@ -51,19 +50,19 @@ BuildRequires: php-zlib
# "php": ">=5.4"
# "ext-date": "*",
# "ext-zlib": "*",
-# "tecnickcom/tc-lib-pdf-encrypt": "^1.4.4",
-# "tecnickcom/tc-lib-color": "^1.12.4"
+# "tecnickcom/tc-lib-color": "^1.12.13"
+# "tecnickcom/tc-lib-pdf-encrypt": "^1.5.8",
Requires: php(language) >= 5.4
Requires: php-date
Requires: php-zlib
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.12.6 with php-composer(%{c_vendor}/tc-lib-color) < 2)
-Requires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2)
+Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.12.13 with php-composer(%{c_vendor}/tc-lib-color) < 2)
+Requires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.8 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2)
%else
Requires: php-composer(%{c_vendor}/tc-lib-color) < 2
-Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.6
+Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.13
Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2
-Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2
+Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.8
%endif
# From phpcompatinfo report for version 2.0.1
# None
@@ -108,7 +107,7 @@ require '%{php_project}/../../Color/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72 php73; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
@@ -129,6 +128,9 @@ exit $ret
%changelog
+* Fri Sep 20 2019 Remi Collet <remi@remirepo.net> - 2.4.8-1
+- update to 2.4.8 (no change)
+
* Mon Jun 25 2018 Remi Collet <remi@remirepo.net> - 2.4.7-1
- update to 2.4.7 (no change)