summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-10-23 14:06:24 +0200
committerRemi Collet <remi@php.net>2023-10-23 14:06:24 +0200
commit3c9a38018b641e39d9526092f1ad45812b0d43c4 (patch)
treee923b5fb8ca85b91dadde393a12cb1f4dca3c575
parent9e19ae6aeef020289b5109088a77cf5897c6480a (diff)
update to 3.2.11 (no change)
-rw-r--r--php-tecnickcom-tc-lib-pdf-page.spec24
1 files changed, 18 insertions, 6 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-page.spec b/php-tecnickcom-tc-lib-pdf-page.spec
index 3ba61cb..8875a5b 100644
--- a/php-tecnickcom-tc-lib-pdf-page.spec
+++ b/php-tecnickcom-tc-lib-pdf-page.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 73d938526784fdbc6b61d3d62d61e825ff5f4006
+%global gh_commit 20b7d448dbb4aacf0d31d09d6535db56afed5d67
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.2.9
+Version: 3.2.11
Release: 1%{?dist}
Summary: PHP library containing PDF page formats and definitions
@@ -26,8 +26,15 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
+# remirepo:1
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10
+%global phpunit %{_bindir}/phpunit10
+BuildRequires: phpunit10
+# remirepo:4
+%else
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.5.27
+%endif
BuildRequires: php(language) >= 5.4
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.14 with php-composer(%{c_vendor}/tc-lib-color) < 2)
@@ -109,11 +116,12 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php80 %{_bindir}/phpunit9" php81 php82 php83; do
+for cmdarg in php "php80 %{_bindir}/phpunit9" php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit10} --migrate-configuration || :
- $1 ${2:-%{_bindir}/phpunit10} --no-coverage || ret=1
+ cp phpunit.xml.dist phpunit.xml
+ $1 ${2:-%{phpunit}} --migrate-configuration || :
+ $1 ${2:-%{phpunit}} --no-coverage || ret=1
fi
done
exit $ret
@@ -123,14 +131,18 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
-%doc README.md
+%doc *.md
%{php_project}
%changelog
+* Mon Oct 23 2023 Remi Collet <remi@remirepo.net> - 3.2.11-1
+- update to 3.2.11 (no change)
+
* Thu Oct 12 2023 Remi Collet <remi@remirepo.net> - 3.2.9-1
- update to 3.2.9