summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-07-02 15:41:39 +0200
committerRemi Collet <fedora@famillecollet.com>2015-07-02 15:41:39 +0200
commit0f4825281f9a28d9b5c0564bc77c9ecaa0b8d93d (patch)
treeaf8e500c58f0ac78b0599b3e2a86ebef2f623d3f
php-tecnickcom-tc-lib-pdf-page: 1.1.1 - New package
-rw-r--r--Makefile4
-rw-r--r--php-tecnickcom-tc-lib-pdf-page.spec104
2 files changed, 108 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-tecnickcom-tc-lib-pdf-page.spec b/php-tecnickcom-tc-lib-pdf-page.spec
new file mode 100644
index 0000000..1a359ed
--- /dev/null
+++ b/php-tecnickcom-tc-lib-pdf-page.spec
@@ -0,0 +1,104 @@
+# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-page
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 37d64e1543c89b01923afdd1ea1e51a2af8dcbf0
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global c_vendor tecnick.com
+%global gh_owner tecnickcom
+%global gh_project tc-lib-pdf-page
+%global php_project %{_datadir}/php/Com/Tecnick/Pdf/Page
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.1.1
+Release: 1%{?dist}
+Summary: PHP library containing PDF page formats and definitions
+
+Group: Development/Libraries
+License: LGPLv3+
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: %{_bindir}/phpunit
+BuildRequires: php(language) >= 5.3.3
+%endif
+
+# From composer.json, "require": {
+# "php": ">=5.3.3"
+Requires: php(language) >= 5.3.3
+# From phpcompatinfo report for version 1.1.1
+# Nothing
+
+# Composer
+Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
+# Upstream package name
+Provides: php-%{gh_project} = %{version}
+
+
+%description
+PHP library containing PDF page formats and definitions.
+
+The initial source code has been extracted from TCPDF (http://www.tcpdf.org).
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+: Sanity check
+grep -q '^%{version}$' VERSION
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p $(dirname %{buildroot}%{php_project})
+cp -pr src %{buildroot}%{php_project}
+cp -p resources/autoload.php \
+ %{buildroot}%{php_project}/autoload.php
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat <<EOF | tee vendor/autoload.php
+<?php
+require '%{buildroot}%{php_project}/autoload.php';
+EOF
+
+%{_bindir}/phpunit --verbose
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.TXT
+%doc composer.json
+%doc README.md
+%dir %{_datadir}/php/Com
+%dir %{_datadir}/php/Com/Tecnick
+%dir %{_datadir}/php/Com/Tecnick/Pdf
+%{php_project}
+
+
+%changelog
+* Thu Jul 2 2015 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
+- initial package, version 1.1.1 \ No newline at end of file