summaryrefslogtreecommitdiffstats
path: root/php-tecnickcom-tc-lib-pdf-graph.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-14 07:09:43 +0200
committerRemi Collet <remi@remirepo.net>2018-05-14 07:09:43 +0200
commitc559821ce3b71e68f8056e57456ae220513609cc (patch)
treea04a0ff3c5952b4f37bd7ce5ba46a0259bf02c3d /php-tecnickcom-tc-lib-pdf-graph.spec
parent3e08affbe68162c7a8732d7310d5e1f4e115677a (diff)
update to 1.4.7 (no change)
switch to phpunit7 use range dependencies
Diffstat (limited to 'php-tecnickcom-tc-lib-pdf-graph.spec')
-rw-r--r--php-tecnickcom-tc-lib-pdf-graph.spec40
1 files changed, 31 insertions, 9 deletions
diff --git a/php-tecnickcom-tc-lib-pdf-graph.spec b/php-tecnickcom-tc-lib-pdf-graph.spec
index 55bdfb6..dcd8939 100644
--- a/php-tecnickcom-tc-lib-pdf-graph.spec
+++ b/php-tecnickcom-tc-lib-pdf-graph.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 29f148cf30939edfc05ce25241f70a2ed7b72bd9
+%global gh_commit 0d50fea95597b0fabd459888849149bfffaf9bbb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.4.5
+Version: 1.4.7
Release: 1%{?dist}
Summary: PHP library containing PDF graphic and geometric methods
@@ -27,11 +27,23 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: php(language) >= 5.4
-BuildRequires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.6
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1 with php-composer(%{c_vendor}/tc-lib-color) < 2)
+BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2)
+%else
+BuildRequires: php-composer(%{c_vendor}/tc-lib-color) < 2
+BuildRequires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1
+BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2
BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2
%endif
+%endif
# From composer.json, "require": {
# "php": ">=5.4"
@@ -40,10 +52,15 @@ BuildRequires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2
# "tecnickcom/tc-lib-pdf-encrypt": "^1.4.4"
Requires: php(language) >= 5.4
Requires: php-zlib
-Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.6
-Requires: php-composer(%{c_vendor}/tc-lib-color) < 2
-Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.12.6 with php-composer(%{c_vendor}/tc-lib-color) < 2)
+Requires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2)
+%else
+Requires: php-composer(%{c_vendor}/tc-lib-color) < 2
+Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.6
Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 2
+Requires: php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 1.5.2
+%endif
# From phpcompatinfo report for version 1.4.2
# none
@@ -87,10 +104,10 @@ require '%{php_project}/../../Color/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -109,6 +126,11 @@ exit $ret
%changelog
+* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 1.4.7-1
+- update to 1.4.7 (no change)
+- switch to phpunit7
+- use range dependencies
+
* Tue Jan 2 2018 Remi Collet <remi@remirepo.net> - 1.4.5-1
- Update to 1.4.5 (no change)