summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-22 09:34:09 +0100
committerRemi Collet <remi@php.net>2022-12-22 09:34:09 +0100
commit8b93e02d5af6eda342cd5601e0ea73c0ffc9e0d7 (patch)
treec9af010098c4f78db43bc2a3786d8da48b5bd6d1
parent41dfe9cf29d34272f98bda32c46af563ca839f4d (diff)
update to 1.5.12 (no change)
-rw-r--r--composer.json8
-rw-r--r--php-tecnickcom-tc-lib-pdf-graph.spec18
2 files changed, 12 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index ae3bb93..cc936dc 100644
--- a/composer.json
+++ b/composer.json
@@ -25,12 +25,12 @@
"tecnickcom/tc-lib-pdf-encrypt": "^1.6.0"
},
"require-dev": {
- "pdepend/pdepend": "2.10.2",
+ "pdepend/pdepend": "2.12.1",
"phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
- "phpmd/phpmd": "2.11.1",
- "phpunit/phpunit": "9.5.11 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "phpmd/phpmd": "2.13.0",
+ "phpunit/phpunit": "9.5.27 || 8.5.31 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
"sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
- "squizlabs/php_codesniffer": "3.6.2 || 2.9.2"
+ "squizlabs/php_codesniffer": "3.7.1 || 2.9.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-graph.spec b/php-tecnickcom-tc-lib-pdf-graph.spec
index 1e0291c..0dec069 100644
--- a/php-tecnickcom-tc-lib-pdf-graph.spec
+++ b/php-tecnickcom-tc-lib-pdf-graph.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 6a622030b23b5354534a6d37d35f1daba5b087c0
+%global gh_commit 736bde3b023e6a980fa49528b077ec611ed17753
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,24 +15,19 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.5.8
+Version: 1.5.12
Release: 1%{?dist}
Summary: PHP library containing PDF graphic and geometric methods
-License: LGPLv3+
+License: LGPL-3.0-or-later
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
BuildArch: noarch
%if %{with_tests}
# For tests
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.0
-%else
-%global phpunit %{_bindir}/phpunit8
-BuildRequires: phpunit8 >= 8.5.13
-%endif
+BuildRequires: phpunit9 >= 9.5.27
BuildRequires: php(language) >= 5.4
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 1.14 with php-composer(%{c_vendor}/tc-lib-color) < 2)
@@ -110,7 +105,7 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
@@ -132,6 +127,9 @@ exit $ret
%changelog
+* Thu Dec 22 2022 Remi Collet <remi@remirepo.net> - 1.5.12-1
+- update to 1.5.12 (no change)
+
* Tue Jun 14 2022 Remi Collet <remi@remirepo.net> - 1.5.8-1
- update to 1.5.8 (no change)