summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-03 09:26:12 +0100
committerRemi Collet <remi@php.net>2022-01-03 09:26:12 +0100
commit478397525ce87c3721da0ce33526f04d581619d8 (patch)
treee28ea4d762108f633d01b6b4df4f161de6d5ca2e
parentc90765f339a3f2bdb952ba42f6be9229e324a17a (diff)
update to 1.5.6
-rw-r--r--composer.json8
-rw-r--r--php-tecnickcom-tc-lib-pdf-graph.spec11
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 694aced..ae3bb93 100644
--- a/composer.json
+++ b/composer.json
@@ -25,12 +25,12 @@
"tecnickcom/tc-lib-pdf-encrypt": "^1.6.0"
},
"require-dev": {
- "pdepend/pdepend": "2.8.0",
+ "pdepend/pdepend": "2.10.2",
"phploc/phploc": "7.0.2 || 6.0.2 || 5.0.0 || 4.0.1 || 3.0.1 || 2.1.5",
- "phpmd/phpmd": "2.9.1",
- "phpunit/phpunit": "9.5.0 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
+ "phpmd/phpmd": "2.11.1",
+ "phpunit/phpunit": "9.5.11 || 8.5.13 || 7.5.20 || 6.5.14 || 5.7.27 || 4.8.36",
"sebastian/phpcpd": "6.0.3 || 5.0.2 || 4.1.0 || 3.0.1 || 2.0.4",
- "squizlabs/php_codesniffer": "3.5.8 || 2.9.2"
+ "squizlabs/php_codesniffer": "3.6.2 || 2.9.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-graph.spec b/php-tecnickcom-tc-lib-pdf-graph.spec
index e3d6497..8971359 100644
--- a/php-tecnickcom-tc-lib-pdf-graph.spec
+++ b/php-tecnickcom-tc-lib-pdf-graph.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-tecnickcom-tc-lib-pdf-graph
#
-# Copyright (c) 2016-2021 Remi Collet
+# Copyright (c) 2016-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 93fe2cec0737314c55bec1c6ac1bab644384d575
+%global gh_commit 07b053c15cf1847b99b0b4e754d298ed470ab58b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.5.3
+Version: 1.5.6
Release: 1%{?dist}
Summary: PHP library containing PDF graphic and geometric methods
@@ -110,7 +110,7 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
@@ -132,6 +132,9 @@ exit $ret
%changelog
+* Mon Jan 3 2022 Remi Collet <remi@remirepo.net> - 1.5.6-1
+- update to 1.5.6
+
* Mon Feb 8 2021 Remi Collet <remi@remirepo.net> - 1.5.3-1
- update to 1.5.3 (no change)