summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-14 07:31:42 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-14 07:31:42 +0200
commit3d099d14688a9c3e02688ebe03b6be2e5701e193 (patch)
treeb064cff9a70879454abe345d456b0e5f957595a5
parent0246d1cda82522aae00b0765dedf8706b67809af (diff)
php-tecnickcom-tc-lib-pdf-graph: 1.1.0 (no change)
-rw-r--r--composer.json40
-rw-r--r--php-tecnickcom-tc-lib-pdf-graph.spec11
2 files changed, 47 insertions, 4 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..0d4d8a5
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,40 @@
+{
+ "name": "tecnickcom/tc-lib-pdf-graph",
+ "description": "PHP library containing PDF graphic and geometric methods",
+ "type": "library",
+ "homepage": "http://www.tecnick.com",
+ "license": "LGPL-3.0",
+ "keywords": ["tc-lib-pdf-graph", "PDF", "graphic", "geometry", "transformation"],
+ "authors": [
+ {
+ "name": "Nicola Asuni",
+ "email": "info@tecnick.com",
+ "role": "lead"
+ }
+ ],
+ "require": {
+ "php": ">=5.4",
+ "tecnickcom/tc-lib-color": "^1.11.0"
+ },
+ "require-dev": {
+ "apigen/apigen" : "^4.1.2",
+ "bartlett/php-compatinfo" : "^5.0.0",
+ "pdepend/pdepend" : "^2.2.2",
+ "phploc/phploc" : "^2.1.5|^3.0.0",
+ "phpmd/phpmd" : "^2.3.2",
+ "phpunit/phpunit": "4.8.19|^5.0.0",
+ "sebastian/phpcpd" : "^2.0.2",
+ "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ },
+ "autoload": {
+ "psr-4":{
+ "Com\\Tecnick\\Pdf\\Graph\\": "src"
+ }
+ },
+ "repositories": [
+ {
+ "type": "vcs",
+ "url": "git@github.com:tecnickcom/tc-lib-color.git"
+ }
+ ]
+}
diff --git a/php-tecnickcom-tc-lib-pdf-graph.spec b/php-tecnickcom-tc-lib-pdf-graph.spec
index a253310..37743f4 100644
--- a/php-tecnickcom-tc-lib-pdf-graph.spec
+++ b/php-tecnickcom-tc-lib-pdf-graph.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 32d1e33a68daa3f578f0f8be50f5ad25bae9a8d4
+%global gh_commit 47d3302930e11722d31002a25091f50922ab6136
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.0.2
+Version: 1.1.0
Release: 1%{?dist}
Summary: PHP library containing PDF graphic and geometric methods
@@ -35,9 +35,9 @@ BuildRequires: php-composer(%{c_vendor}/tc-lib-color) >= 1.8.0
# From composer.json, "require": {
# "php": ">=5.4"
-# "tecnickcom/tc-lib-color": "^1.9.0"
+# "tecnickcom/tc-lib-color": "^1.11.0"
Requires: php(language) >= 5.4
-Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.8.0
+Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.11.0
Requires: php-composer(%{c_vendor}/tc-lib-color) < 2
# From phpcompatinfo report for version 2.0.1
# nothing
@@ -107,6 +107,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- update to 1.1.0 (no change)
+
* Fri Mar 4 2016 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
- update to 1.0.2 (no change)